Why is it so difficult to save a CSV from a List?

Yes, that happened when I went to sae the last graphic. I've deleted the duplicates now. will send the aia again.

Shoppy (1).aia (55.3 KB)

I don't have the time to go through your app. So like I said, post a simple test aia that only affects the (supposed) problem with the MFile extension.

Because there shouldn't be a problem with that - on any Android version.

Yes, i understand. Everything in the app is linked, so how do I create a test aia. You've seen the blocks that affect the MFile extension. So unless there is something wrong, there is a problem. To be honest it's doing my head in.

I reiterate, thanks so much for your help.

Try this example project, works for me with companion and compiled

MFileTestExt.aia (23.9 KB)

1 Like

Screen1 is broken.
I don't have the time to examine it further. Put the blocks in the backpack, create a new project, add components and extensions again and then the blocks from the backpack.

I think it's the best solution, Mike's project is corrupt

1 Like

Indeed - the same arrogance from Microsoft cost them dearly in terms of hobby developers using Basic - just about everyone ditched them within months.

Yes, your test AIA worked for me too. I'm gonna have to go back to the drawing board on this one.
You may be correct, but where is it corrupt?

Something strange happened today. I had to reinstall the companion, and open it in Legacy mode to get it to work. What's that all about?

Jeez. Things are strange today. I must have got a corrupt version of the Mfile extension, because every time I go to use it, I get this....

Show your Block using Mfile - it could simple be a typo.

Remove mfile and relative blocks, your project does not run, listview1 missing.

good choice.

This has nothing to do with the MFile extension.
Delete all assets from the Companion app first and then try this one:
Shoppy_2.aia (55.6 KB)

And explain what you are trying to do here:

Thank you for finding time to look at my work. I deleted all the stuff in AppInventor/Assets directory, and as an added precaution deleted and reinstalled the companion app. Whatever you did, worked, and amazingly my original Shoppy worked too.

So your problem is solved?
If so, close this topic by clicking on Solution at the best answer.

I doubt this - at least that the CSV file is saved (in /Documents/...).

Yes, you are correct. The CSV is saved, but contains nothing but " ", " ". But that's for tomorrow. I noticed your little red dot with the huge ?. Too tired now, need sleep. Your help has been invaluable.

No, not with your original Shoppy.aia.

A post was split to a new topic: Filepicker AIA Help