Why can't I use Font Typeface property in Companion?

It was working yesterday evening on Companion real device. But today it suddenly stopped working after I updated the companion app to 2.66 on BlueStacks emulator. So now I am forced to use the built-in sans serif and serif fonts. What could be causing this? (by the way I am using free no-copyright fonts)

Does it work on a real device with companion 2.66?

Yes, it does. That's very weird.

Have you tried other emulator than BlueStack?

So it looks like an issue with BlueStacks.

Android version?
If < 10, then it doesn't work with Companion:

1 Like

..... it doesn't work with nox player as well .......

As Anke mentioned, check what android your emulators are emulating. Perhaps in the emulator settings it is possible to change the android versions.

If you have Android < 10 "manually" copy yourfont.ttf to /storage/emulated/0/AppInventor/assets

Maybe the emulators have 7.0 ??

Ok I will try! :slight_smile:

Seems like Nox is emulating version 7.1.2 ...

But anyways, I tried your instruction @Juan_Antonio it didn't work....

Even I tried @Anke 's instruction also, it didn't work though :slightly_frowning_face:

You're using an OTF file. What if you switch to a TTF file and loading it from the assets?

It also doesn't work with TTF fonts. Just tested it, and similar error..

It works fine on Android < 10.
It seems you are doing something wrong.

Post this: