When I am creating tags in the clouddb they are not appearing in the tag list

Hi I have created an app which works with the database(the database is the main thing). However, when I am creating tags in the clouddb they are not appearing in the tag list(I have created a list view and set the elements from string to the value of the tag list). Because of this, I switched to firebase DB.But the problem is that when I try the main function in my app, it crashes(It closes for no reason). Can anyone give an immediate solution Please

We can't give you a solution based on next-to-no information Sai.

We need to see your Blocks.

I fixed the clouddb problem but my crashing problem needs help i will be sharing my aia file shortly

HackathonApp (2).aia (22.2 KB)

Please tell me what is causing the crash

OK, I have 20 minutes to spare, I will take a look.

What are you doing with the App at the moment it crashes?

Thank you so much!!! Also please take a look at the login page.

It crashes whenever i am switching screens
I tried other methods here and in the internet but they were not fruitful

Is true to say the App does not crash going from Screen1 to any other Screen? The CloudDB! GotValue block is very meaty.

I don't understand properly

The app mostly crashes from Screen1 to Service screen and ScreenFam

Ok found the issue. You cannot use "open another screen" to go back to a Screen:

This will open an additional Screen1

Solution: Pass the data back to Screen1 via TinyDB.
This will take the User back to the original Screen1

Thank you So much I will be forever Indebted to you

Same solution for ServiceScreen

Need to have something for ScreenCare - totally blank screens are actually a process issue too

You can also pass the info like this (instead of TinyDB):


However, instead of sending and checking for "Nolog" in Screen1, how about using True or False? Much cleaner.

It worked for Sevice Screen but the app crashed at ScreenFam



Also, unattached blocks are not good:

Delete this Block:

Note, never name a Procedure "procedure", it will crash the App.

Oh Maybe that's what's caused the problem