Whatsapp is not installed, Activity Starter Resolve Activity method returns empty string

I noted that all my MIT applications embedded with whatsapp activities cannot be used. It was still working yesterday. The actual error states " Whatsapp is not installed". I tested my app with other users who also reported the same error message.

How to start Whatsapp/send a message with Whatsapp

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select "Download Blocks as Image". You might want to use an image editor to crop etc. if required. Then post it here in the community.


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

Which Android version?
Connect your device to Companion make a right mouse click on this block:


"Do it" and post the result.

See also here (point 4):

How to ask a question (open new topic)

and here:

does the example project work for you?
you can download it here App Inventor Code Snippets | Pura Vida Apps


This is the error message. How does it resolve this error? I am using android version 10.

you forgot to answer this question


Hi Taifun, My codes are the same as the example project. I checked each line against the example project and they are exactly the same. The "call activitiystarter1. resolveactivity still returns an empty string and as the result, my app displayed the message "WhatsApp is not installed" text. From what I have read online and the material provided from the reply, it seems that this is caused by android 10. An update on the version could be the cause. Submitted for your advice, please.

I now tested example 2 on an Android 11 device and can confirm the issue...
I also tested example 1 to open WhatsApp, this still works after ignoring the ResolveActivity method

there already is a bug report here

try the sharing extension and its Whatsapp method...

I just tested it... however it works for Whatsapp text messages only...
for files I get a notifier "data format is not supported"... it looks like I will have to take a look...

there are also other Whatsapp extensions available... you can find them after doing a search in the extensions directory here App Inventor Extensions | Pura Vida Apps


Hi Taifun, May I know if there is another way to code without using the activitystarer1.resolveactivity method. Or should I accept that this is an inherent limitation of App Inventor 2? Submitted for your advice, please.

the second example does not work anymore for some reason...
just use one of the Whatsapp extensions, for example the mentioned Sharing extension


1 Like

Thank you, Anke for the reply. I tried calling the activitystarter1.startactivity. It didn't work and it return an error on connectivity. I am not sure if this is a common problem or is it just me. haha.

If you are running Android 11, you're likely being affected by a security change in Android that prevents apps from querying for other apps on the phone with explicit mention in the app's manifest (the intent is to reduce apps' abilities to fingerprint and track users). This causes complications in particular for the companion since we can't really know at publication time what apps people will want to query for (e.g., you could write an app in App Inventor that queries for another App Inventor app, known only to you). I expect we can at least partially address the issue in compiled apps by extracting this information from the designer properties for the ActivityStarter to populate the manifest.


I got the error 601: No corresponding activity was found if I uses the call start activity command.

Thank you for sharing. I half suspect that this is the source of the problem.

I have the same problem: error 601: No corresponding activity was found
Can anyone help me ?

use another solution, i.e. not the activity starter
see again Whatsapp is not installed, Activity Starter Resolve Activity method returns empty string - #9 by Taifun

Thank you, Taifun. I have managed to resolve the problem with your extension.

Thank you.
But how can I select a contact from the address book with your extension ?