I have recently seen that some things have been updated about webviewer, but the truth is that I do not understand anything of what it says ...

Here is the text:

Implement a universal URL format for assets in WebViewer (# 2272)

Use file: /// appinventor_asset / or http: // localhost / to access your assets in a companion / build agnostic way.

before I used the following way to load html files inside webviewer:

file: /// android_asset / ????? .html

When i was loading from the build APK and:

file: /// mnt / sdcard / AppInventor / assets / ?????? .html

When i was loading up companion elements to test ...

By the text this has changed? ... looks like it by the update text, but im not sure because when I try:

file: /// appinventor_asset / ???? .html, In companion ... nothing happens, well something happens, it crashes 100% of the time forcing me to restart companion again, tried with several phones and its always the same, crashes.

the same happens when i try in build:

http: // localhost / ???? .html

My app crashes on loading, i dont get it, can someone explain this to me?

Try (building and running) this simple aia project

testwvr.aia (1.9 KB)

Built and tested here for http://localhost/ and file:///appinventor_asset/, app loads OK.

1 Like

Fails on native Emulator weblink


on device (Samsung A10 tablet, Android 8.1 ) using Companion

This however, works using Companion on Tablet

Your example needs to be compiled @TIMAI2

Just tested by compiling and installing the apk. This example only works with the compiled apk. as presented by Tim. It fails using Companion or using the stock emulator. :frowning:

Worked fine in companion for me on Pixel 3XL Android 9 (genymotion)

which means the example does not work in Companion mode using a real device (at least some real devices) or when using Companion for Android 9- devices.

To keep you happy.....

HTC 10 Android 7 (REAL DEVICE!! - the best I have to hand to test)

The supplied app works in both Companion mode and as an installed apk

wonderful. The example still does NOT work with a Samsung A10 Tablet running Android 8.1 .

This sounds like a problem with Companion on some versions of Android or hardware.

I can confirm it works on all my devices but it has to be compiled (APK build) Like SteveJG said in companion it wont work... on 90% of devices.... its a Companion problem, has to be.

I have one last question...

Will i have to update all my apps from playstore with this new linking standard?

No, the previous methods still work.

Make sure you are updated to Companion version 2.60. It won't work in earlier versions. It also won't work on Android versions prior to 3.0 Honeycomb because the needed API wasn't added until that version.

  1. Companion failed to update automatically (possibly as I had 2.59u installed?)
  2. Companion 2.60u works with Tim's example
  3. The stock emulator fails to provide an upgrade message; consequently does not upgrade.
  1. Correct, versions ending in u came from App Inventor, not the Play Store, and the Play Store will not upgrade them to a newer version.
  2. As expected
  3. The stock emulator runs Android 2.1, so unfortunately even if you do update it, the behavior won't work. The beta version of the new Windows emulator runs Android 9.0, so it should be fine. To trigger an update, you can use the Help > Update the Companion menu item once you've connected to the emulator.

Nice to know after the fact..you might improve the documentation to release of nb185?

I re-installed ..Tools_2.3.0 after a lot of frustration. this gem among others

because the real install address is Program Files(x86) .. yuk.
finally upgraded the stock emulator and
get this running Tim's example

The beta version of 'new Windows emulator' ? The latest version I loaded then unloaded when I discovered the WebViewer would not work properly several months ago.. So, there is a NEW version of the experimental emulator that is fixed?

It might be fine if you provided a link here . Hopefully the new emulator has a version? If I had the link, I could try the 'new' because at present I have a useless emulator, courtesy nb185 and Companion 2.6u.

connected to the 'new' emulator? This " use the Help > Update the Companion menu item once you've connected to the emulator." doesn't make a lot of sense out of context.

Sorry... you are trying to help but not succeeding. :frowning: