WebViewer problems with popup

Im trying to use mit app inventor to openup my website that is port-forwarded and requires a name and a password to get into. The problem is that mit app inventor doesnt really want to show the popup. It looks something like this:
If the website doesnt require me to log in, then the website is loaded.
This is the error on the app.

http ? This is a local server or insecure internet site ?

Its a http site. Basically a local server that is forwarded to a public ipv4 address with a port that can be access from anywhere.

From my browser on computer:


Aside from this, you should use a different network to your local server when connecting the phone, or compile your app and turn off wifi on your phone so that you try to connect over a data connection.

Right now the website is offline, thats why it cannot be reached but my friend has tried to connect to the website and it worked. It even works through my phone. But only mit app inventor doesnt want to load it. If I remove the requirement to log on to the website, mit app inventor does load the website successfully.

Show the html (when setup with the login requirements)

Hard to show you because the html is premade and cant really find where it is, but I made the website online you can try it yourself. Ofcourse you wont get past the log in stage, but atleast you can try it in mit app inventor and see what im talking about