Webviewer not showing Math Equation

I tried to display math equation using jqMath in App Inventor using tutorial from Displaying Math Formulas (google.com). The WebViewer display ERR_FILE_NOT_FOUND. The same thing happens when using the aia file in the tutorial.

Are the links need to be updated?

The result is supposed to be like this.

Change URL to http://localhost/formula.html

I have changed the URL in GoToUrl to http://localhost/formula.htm. The WebViewer no longer display ERR_FILE_NOT_FOUND. It is now showing 404 Not Found.

Try to renane file to html instead htm

Android version of your phone ?

When changed to html there is nothing shown up, empty.

Save file to ASD and read from ASD directory

Android version 10

I'm sorry what is ASD? How can I do that?

Application Specific Directory Try this way using FileTools extension

1 Like

Improving, thanks. The html file has shown up but it is not converted into equation.

I guess the html file url is now correct, but not the url of the three files in the initial script variabel.

Fixed it, all instances of file:///mnt/sdcard are converted into http://localhost.

End result

New version

<link rel="stylesheet" href="**http://localhost**/jqmath-0.4.3.css">
<script src="**http://localhost**/jquery-1.4.3.min.js"></script>
<script src="**http://localhost**/jqmath-etc-0.4.6.min.js" charset="utf-8"></script>

Old version

<link rel="stylesheet" href="**file:///mnt/sdcard**/AppInventor/assets/jqmath-0.4.3.css">
<script src="**file:///mnt/sdcard/AppInventor/assets**/jquery-1.4.3.min.js"></script>
<script src="**file:///mnt/sdcard/AppInventor/assets**/jqmath-etc-0.4.6.min.js" charset="utf-8"></script>

Updated blocks:


Here's the final working file.
p167Di_javascript_formulas (1).aia (75.2 KB)


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.