WebViewer - error using url http: // localhost


Trying to find an alternative to the current problem with set WebViewer.WebViewString on iOS, I was trying an alternative consisting of passing the parameter in GET mode through the url.

In doing so I think I have detected if http: // localhost is used. If in the url I put the real address of the html file it works correctly, but if in the url I indicate http: // localhost, if I run the compiled one, when I pass variable it does not find the page if I pass value and if I do it through AI Companion directly exits the application. When I don't pass a parameter, both the compilation and the execution with AI work correctly.

I have done the tests with a Xiamomi Mi A1 with Android version 9

I include the AIA and show you the content of the html file that I run.
pruebas_varias.aia (2.8 KB)




Note: On iOS, running under AI Companion and using an external url also works fine.

I can confirm, having tested on my Android 10 emulator companion:

This crashes the app:


This works OK:

@TIMAI2 Re. the crashing, can you try the companion on ai2-test? It does have a bug fix related to the http://localhost/ method and it is possible that fixes the issue.

@Luis_Azuaga The iOS version also has this problem and we have a fix in the queue. It seems like we need to backport that logic to the Android version.

1 Like


It crashes the app in test-ai2 as well :frowning: