Web Page does not work

Hi, I am doing a project with my students where they have to design an app. It has been a long time since we cannot work because the web page does not work, at the end of the post you will find an attachment where you can see the error message. I tried to solve the problem in a lot of ways and none of them had worked. Can you help me, please?

Thank you,

Laura Arévalo.

What browser are you using?

Use Chrome or Firefox

No idea if this is related but on firefox I get this.

On Chrome we get this.

On the other hand if you go through Hour of Code, that works.

I had a momentary popup opening my first project in the Brave browser.
I am okay now.

However the release notes at http://appinventor.mit.edu/ai2/ReleaseNotes.html
come back ** appinventor.mit.edu refused to connect.**

Using Chrome, and https://appinventor.mit.edu/ I have no issues; using Firefox I get a Problem loading page error. http://code.appinventor.mit.edu/ works fine. Using appinventor.mit.edu/ I get an error.

– Steve

@Laura, were you able to use this site before?
Your message indicates you need to refresh browser cache, usually in your browser settings.
That’s a different problem than the thread hijackers’ problem.

I followed up with @Laura_Arevalo_Doming by email with instructions on clearing the Safari browser cache.

The issue with appinventor.mit.edu not responding is a separate problem due to an infrastructure issue here at CSAIL that we are working to address.

My class cannot get on to the MIT App Inventor website. Below is the error message:
Request Blocked
appinventor.mit.edu:443 is blocked at this time
dial tcp connectex: No connection could be made because the target machine actively refused it."

The website should be back up now.

Confirmed, it’s up.

One of my students is facing the same issue. Did you find a way to make it work?