vknow360/CustomWebView doesn't load webpage on local network

I tried to load a local webpage I used (access point control page) as example but the view is blank just white page. Although it works fine from browser installed on the phone.
When I used other website (http://www.google.com) it works fine and loads successfully.
So What can I do to make it load page on local network ?

the device on which this is running and the device through which you are accessing has the same network connection?

yes as is the router page. This is the same router the device is connected to.
And When I run it from browser it works fine.

Now I'm guessing the issue is when accessing on browser it says "This site's SSL certificate has expired or is untrusted. There may be a security risk if you continue." and I must press continue for the page to load.
So maybe this SSL certificate needs special handling inside MIT app inventor. Is that make sense ?
And if so How can I handle it inside the application ?

I fixed the issue by adding invisible WebView and checked the option ignoreSSLErrors

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.