Virtual keyboard question

I have a page where i enter input data in a Textbox. When i click on the textbox and the keyboard is come up it is push up the whole screen. I want it to appear on top of my screen, not below an push it up.The screen is not scrollable. Can i do something to prevent the push up? I don't see anything regarding to this in the Gboard options menu.

It is weird, because if i remember correctly earlier i had the opposite problem in an other app. The keyboard did hide the textbox input. Was there a change how is it working?

Tested it on an other device.
It is really works differently than before.
No matter the screen scrollable or not. No matter if fixed or responsive. The keyboard always push up the screen, more over it is srink it but in a weird way?
It is worked before differently, depending the screen scrollable setup. Now that has no effect.
I don't think it is android related update because other apps seems works normall, so i think it is AI2 related BUG. Maybe @ewpatton or someone else from the dev team can confirm it.

This is not a bug. If the text field in which you want to enter text is low so that the open keyboard would cover it, the screen moves. If the text field is high, then the keyboard does not move the screen.

Yes, that is the normal behavior and it is worked that way before, but now it isn't.
Tested on two device, android9, with several screen and textbox options. Even in a pure screen with only a textbox, the keyboard shrink the screen, regardless of the textbox position. Try it.

This is how it works for me and also android 9.

Hmm. Made more testing. Portrait mode works normally, landscape doesn't.

Tis is the screen. The keyboard top is below the close and save button. The textbox is the save profil name.

And this is when the keyboard came up.

Interestingly the screen scrollable option has effec on it, but is is works the opposite way then before, i think, and i have to redesign my screen a little because of the responsive design, but i think it will work.

Seems with my redesign well be ok with the screen scrollable option, but just to prove it is worked the opposite way before, here is my question from march:

Yeah. I only use the portrait layout. That's why it works fine for me.

Ok, but again. It was different in march. But never mind. I solved it.

I had the same problem as you and not knowing how to do it and not being a good developer I solved it this way.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.