Vibration of the sound component and the player don't work (Android 11+)

I was trying to press a button and vibrate in my app but it doesn't work, any help please?

Are you running on a live device, or are you running on an emulator?

Is your Android system set to allow vibrate? I think that may be necessary.

You can try with a Samsung Android device swiping down from the top of the screen, tapping the sound options, then turning on vibrate. For other Androids, press a physical volume button, then tap the Ring icon to switch to Vibrate mode.

Then try your code. :slight_smile:

I'm using my smartphone and I've tried it on other devices and it's the same, could someone please test if it works?

Tested on Google Pixel 4a (Android 13) using companion app.


Both work just fine

Hello Fernando

I ran the same test as TimAI2, Companion & APK, on Android 12. Same result, both work fine (I did not adjust any phone settings).
TestVibrate.aia (1.8 KB)

Vibrate in mit apps in working on Android 12.
After update my phone(Motorola g72) to Android 13, not working vibrate.
Please fix this bug.
Vibrate not working in any other mit app inventor apps i made.
Thanks dear

Check your device settings for vibrate?

In other apps vibrate is working.
Only in apps i made by mit, vibrate not working.
Do you want send to you and check it?

Do you have a different device, with android 13 on which to test ai2 apps?

Yes i have another device(huawei nova 5T).
Must check by that.
But use my app before update to android 13. Working correctly.
After update to Android 13 started this problem.
All permission for my app is allow.but not working vibrate for apps made by mit.