Using google calendar still not possible (November 2020)?

Asking this in November 2020, as it seems im running into circles from researching.

So it still seems not possible to get any access for read / write, because oauth2 is blocked from being used in webview?

Sorry for the shortcut, but i'm done after trying everything for about 10 hours.

Maybe this can help you. This is for writing an event in Google Calendar with the help of an extension.

This is the sticking point, it is Google's causing, not App Inventor, that will not allow a user to authenticate in a webview (even if you do try to change the user-agent). The user would have to go out to Chrome, authenticate, then back into the app, and use a webviewer to "sign in", then send requests to a google apps script web app to perform calendar functions on their own calendar/s.

Although this is not for the google calendar, see here for how I approached this for Google Drive functions:

1 Like

Wow nice, thanks. Different approach. But does the job well.

Currently i'm trying to change the start and end time with all different approches and key:value list pairs.

Do you still use this and does the insert work for you?

Never does anything to start or end time to my calendar entry.

1 Like

Hi @TheJupiter732

Did you use the xactivitystarter extension that you have to use to make this work?!msg/mitappinventortest/IM9yDZDAm-Q/IcxUtvX2BQAJ

Ok, after trying out many things it works now with the original.
I even tried to use the original activity starter. (According what you said that was a mistake anyway)
Must have been a typo or something, i don't see it anymore.

Now my reminder does not work ... do you see any error?

First i used a string as minutes, now thats fixed.
I used "reminders" and "l.reminder" (l for long int again).

I try to set multiple reminders (for my sweet time forgetting brain), i hope that is even possible, but it does not even work with one.

Data gets passed correctly, as it seems:

Try not to use empty sockets in the list you construct. I think only one reminder is possible.

This worked for me, tested just yet

1 Like

Did you try changing the minutes for the reminder?

There is always one with 10 minutes there standard.

If i use 10 mins it works for me too, because the 10 min standard reminder is there.

But it never changes, if i use 30 mins or 60 mins.

Using only one reminder and deleted all empty sockets.

I see that now to. Still experimenting :grin:

How did you find the keys for that?
Is there a documentation?
I only tried out official API keys in my struggle to find a solution, but they are not what you use.

Sometimes trial and error, some with samples from others.

Hmm wow ok, i did not find the keys you use anywhere, must have been lot of guessing work.

From what i can see about reminders is, that they need ID, method and minutes.
And they are somehow an own table that is integrated into the calendar, if i understand this correctly.

I guess i will skip this for now, i can't even guess the command you would need to get the ID of the event you are currently creating.
Maybe even Android just adds the reminders after the event is created.
(Save event -> Create event -> Get ID -> Add reminders).

That would mean, you have to make another call after you saved the current event,
to get the event ID of your last saved event and add the reminders.

There is also everywhere in the documentation mostly starttime, differently capitalized, in every insert for an event.
No clue how you guessed beginTime, not even to speak about the capitalization.

android.intent.action.VIEW might be a good start, users suggested to use the MAX ID to get your last created event, but that is not failsafe they guessed, and i would second that.

1 Like