Unresolved issue with Android 13+ permissions

Hello again, I am suffering greatly from this problem and it has not been solved yet. I tried such an example and did not succeed in the Android 13+ problem, so what is the solution?



Where is this ?

What are the file paths in your textboxes 3,4,5 ?

This link txt file read from path /filedata/items.txt

Yes but where is it ? What is the full path to that file ?

Internal storage filedata/item.txt

Don't worry, I will guess...

/storage/emulated/0/FileData/Item.txt ?

This is created by your app, or placed there by some other app ?

andriod ver 10 is ok but android ver 13 + can not work

I am trying

No it didn't work :face_with_head_bandage:

What didn't work ? Getting the file path ?


You are trying to access files in the Initialize event before having received permission...

First get permission, then read the file


You are correct, but I was not able to obtain permission

I always read, and then re-read this:

and this

and this too

before I do anything that might be reading or writing text files outside of the ASD (and in it for that matter)

1 Like

Move the blocks to access the files from the Initialize event to somewhere else, for example a button click event

Then get the manage all files permissions before accessing the files


From looking at your blocks, it looks like you are checking if the SDK is >= 33 and then asking for READ_EXTERNAL_STORAGE permission. This permission no longer exists in newer versions of Android you have to instead request individual permissions like READ_MEDIA_IMAGES, etc. So effectively, you are asking for a permission that doesn't exist and the OS is denying you, which makes sense.

@ewpatton Do you need a permission to read a text file from Downloads or Documents ? (with the File component)


I sent the text file, the aia file, and pictures of the blocks
Andriod Ver 10 Is Working But Up To 12 Not Work

Item.txt (26 Bytes)

Adam87777777.aia (698.1 KB)