Undo doesn't manage changes in parameters of procedures right

When I step back (undo) after making a change in parameters of a procedure. It doesn't do it right. De changes in parameters won't come back.

just with one undo?

Can you show an example of what is happening?

I have tried it. It doesn't indeed set back de parameter in de related procedures. With just one undo

When I delete parameter "'entr". and try to step it back it doesn't set it right back in the related procedure. I can't step it futher back.

So with the blue gear icon you remove the inputfield "Entr" in the procedure and then you try to get that back with an undo? Is that what you are trying to do?

Yes indeed. That is the case...

I just tried it and it works for me. Can you give more info about the system you are using. And does it still not work if you make a new project with a single procedure to test?

I'm working with windows 10 and 11. Both systems gives this issue. I'm going to try it with a simple project.

After a new try the problem here is the same. It does step bach but forgets the change in the paramater/input list. And goes futher with set back the earlier changes


Oh I see now. When you do an undo the to procedure is at is was but the call procedure is not changed. Let's see what the developers of App Inventor think. I assign one of them.

Yes that is what I ment. Thanks...

I did not have such a problem. Instead, another problem happened