Unable to Use CloudDB

Hello There!
I am making an app using Cloud DB, it seems to work perfectly with the companion but when I download and run it, the Cloud Service doesn't seem to work. I receive some notification saying
"CloudDBError: java.net.SocketTimoutException: Read timed out". Please tell how do I fix this?


You did not share your Blocks so anything said is speculation.

  • You might need this Block
    clouddberror in your code to trap intermittent errors.
  • the default CloudDB is intended for testing. The CloudDB server occasionally glitches on weekends or during periods of high usage by developers. You might just try using the service later or use your own Redis server to avoid such issues.
  • you might have a slow Internet connection that occasionally glitches or are sending large amounts of data. You might un-tick the CloudDB SSL error Property. Doing that might allow you to proceed.

Still having issues? You might read https://community.appinventor.mit.edu/search?q=clouddb

1 Like

@SteveJG this is the code -->


I forgot to tell that I had received another message when I opened the app after an hour saying
"CloudDBError: java.net.UnknownHostException: clouddb.mit.edu". Sorry for telling this late. :neutral_face:

I have run some tests on the MIT CloudDB and on my own online redis Server

In both companion mode and with compiled apps, my test project worked OK, without any errors. Therefore there does not appear to be an issue with the MIT provided CloudDB nor with a correctly configured self provided redis server.

You will need to look at your configuration and your blocks to identify where the issue lies. It could be a network issue, in which case you may need to run a network check in your app before connecting to cloudDB.

I have a fast network connection so that cannot be the problem. Plus I use extreme data usage mode
(maximum data is given to the active app).

Do you have Use SSL checked ?
Have you confirmed your configuration: Url/Port/Token/ProjectID ?
Have you tried a simplified test project?
What error message (if different) do you get back from using the error block as suggested by @SteveJG?
Have you confirmed that your app is connected to the network?

Sorry, but I don't know how to use the error block.

Yes I have SSL checked and I have already made a simpler version of the app earlier, I actually was trying to modify the Chat-App script from my school curriculum.

You just drag it out into your blocks editor, then set the message to either a label or notifier

Well ok I will try as you said.

also i sometimes have this problem of numerous errors from clouddb. How should I do for confirmed your configuration: Url/Port/Token/ProjectID ??

Just check that you have all of these entered correctly for your redis server

can you send the .aia file?