Unable to see sdcard with TaifunFile

I used to find available directoty with TaifunFile with no problem, but today i have a trouble with it:
a very simple app to test it:

result obtain with companion
but if I run apk I can't see /storage/3EA0-EAAAE ! (see screenshot below)

i reboot my phone with same result !

Which Android version are you using for your tests?
Did you grant storage permission?
Probably you have to set the default file scope in the screen properties to Legacy, however I'm not sure...
Just post your test project and I I'll take a look later...


It should work even without any storage permissions (READ permission).

Try with FileTools from @vknow360.
Which version of TaifunFile do you use?

1 Like


:joy: :joy: sorry I hadn't my glasses ! :joy:

1 Like

version 12 the same I used in old apps without any problem !

version 10 I didn't changed my phone and version didn't changed.

yes I did:

here is aia:
tst1.aia (33,3 Ko)

same result...

1 Like

Try this one: tst_2.aia (63.4 KB)

1 Like


As said, it is not necessary to grant any storage permissions.

Result on Android 9 (of course without storage permissions):


same: with apk:

and with companion:

Then perform a factory reset or better yet, buy a new device. :wink:

I've 20 test devices and it works on all of them, which have a removable (micro) SD card.

but... few days ago, I worked with AI appp i wrote with TaifunFile.AvailableDirectory without any problem...And they still working !

Try this one:

1 Like

If my APK doesn't work on your device, there must be an issue with your device / MicroSDcard.

1 Like

Yes it works well !

does it mean AI has a problem when building my apk ?

How should I know?
Which OP, which builder, browser, AI2 (online) or AI2Offline, ... ?
(Questions upon questions ... :wink: )

I didn't change PC neither OS (windows 10) neither browser (Firefox...maybe an update !)
next to your post i tried on edge in order to know if it is a problem with last firefox update, and it works....
so i tried again with firefox...and it works !!!!!
I have no idea about what happened !
I'm dreadfull sorry because it was not a problem on my code or on extension or on phone, but thanks a lot for your helps...

1 Like