Unable to run java_dev_appserver

Hello everybody,
So, I was working on app inventor sources and it was working very fine before, but just today i got an error which is now irritating me. The error is somewhat related to Google Cloud SDK and python,
actually when i am running

 java_dev_appserver.cmd --port=8888 --address= appengine/build/war

Just the moment i am hitting enter it is showing me some api-ms-win-core-path-|1-1-0.dll is missing


I started searching google and stackoverflow for this and got this, and from here i downloaded that api-ms-win-core-path.... file and then i pasted it to the main folder of Google Cloud SDK and it's bin folder too but after adding that I am encountering another error which is this


I don't know the reason of both the errors
Help will be appreciated

Thank You

Have you recently updated your Google Cloud SDK? I've seen the error in question on Windows 7 in other contexts and in those scenarios it was because newer versions of Python are no longer supporting Windows 7. If that's the case here, you'll probably need to roll back your Google Cloud SDK installation to a version that relies on a version of Python compatible with Windows 7.


Yess, now i can mess up the things that are causing the errors, actually just before sometime i got a message while running java_dev_appserver that Google Cloud SDK is asking for update and I did it, and from after that I'm getting this error,
Anyways Thank you sir :blush:

I had a zip file of Google Cloud SDK which I extracted and then copied it's bin folder's path to environment variables but when I'm doing the same after deleting the previous Google Cloud SDK folder to roll back in getting same issue again, i tried searching of the issue and got that I need to copy api-ms-win-core.... File to SysWow64 folder and system32, after doing this now I'm getting same error which was this

I'm still confused how to solve my issue

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.