Unable to load update from app inventor server (server not responding)

Unable to load update from app inventor server (server not responding)

Any ideas on the issue above? This comes when updating the companion app during the first run.
Only half of the computers within a class have this problem, The other half updated fine, without problems. Same hardware and configuration on all PCs.


Same issue here. Anyone have any ideas?

@lmarsengill What your issue is might be different. You might read https://docs.google.com/document/d/1NbJRyCA9udxdU3oNyadR0fuvNglijYR7X3mVB_ZIeNU/pub

When you try to update you probably see this screen…

Click OK, then follow the instructions that are shown as pop ups. Follow the advice exactly. Try again to upgrade and let us know what happens.

@dkalamata Dimtris, an update issue is sometimes that a computer has insufficient memory for the updated Companion software… could it be that the computers that do not update are older and have less memory? Are the problem computers very different from the computers that update properly?

The aiStarter requires Admin privileges ; is it possible when you attempt to upgrade on these PCs, the PC does not have Admin privileges set and that causes an issue regarding the Companion upgrade?

Have you solved your issue yet? The link above, suggests things that could inhibit installation/upgrade. Perhaps one of them applies to the computers that refuse to upgrade the Companion.

1 Like

Then clicking “Ok” takes the message box away and there are no other instructions.

@lmarsengill Sorry, I don’t know. this appears to be an issue where MIT’s server is not responding. Your PC virus software or something else is blocking access ti tge server or the server is down is what I guess.

I’ll mention this to MIT.

1 Like

Thanks. My son is using this in his 6th grade class and I am trying to install at work. I will check with the SYSADMIN and see if it’s being blocked in the firewall. Also, I will try to install at home, where I control the firewall with the pfSense box.


1 Like

You may also want to check the console of your browser’s developer tools. If you’re able to load the website, you should also be able to download the update from said website. However, it might be the case that antivirus or other software might interfere with successfully downloading the update since it’s a (base64 encoded) APK file. The error messages in the console might help us better diagnose the exact reason for the error.

1 Like

Thank you everyone for your help!
I haven’t solve the problem yet… This is what i get from Chromes’s dev tools and the extension i added to solve this (Allow CORS: Access-Control-Allow-Origin). Unfortunately still no luck

No Antivirus on the PC and Windows Defender is off…

dev tools

Hi @dkalamata

The errors about CORS are okay. There is some functionality not in the old version of the companion that App Inventor tries to use, and the CORS error is due to the fact that the old companion does not support this. App Inventor proceeds normally in this case.

The more important thing here is that you’re getting this 403 error for the CompanionUpgradeHelper.asc file. This shouldn’t be happening. If you’re in a school environment, you may want to check with your IT department about whether there are any HTTP proxy servers used to filter Internet access. It might be falsely flagging the companion and preventing you from loading it by returning 403 (not sure why it would affect some and not others).

If you go to this link in your browser, do you get any more details? Does it show you a Google 403 error page or something else (please include a screenshot)?

Dear @ewpatton,
I took a PC at home to test the update outside the school environment. It was working fine! The school’s ISP is applying a safe internet filter which, as you mentioned, is filtering the connection.

This is what i get when loading the link you provided:

I will contact the ISP, and ask them to remove restrictions from the companion.
Although. shouldn’t be the same for all computers on the network? Why some are updating without problems… anyway i’m sure this will be resolved now

Thanks again for your time and help!


Thanks for letting us know. Please follow up once you hear back.


All perfectly working! Many many thanks for your help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.