Unable to install new apk

Hi Everyone,

I Tried multiple time to install an updated version of an .apk I made.

Now I can’t install the apk on the phone and have the following fail message “The application was not installed because the package seems to be not valid”.

I’m running the latest version of companion and using Android 14 with One UI 6.1 on a S23 Ultra.
Also, I tried to install an older version of my app which was previously working but now it fail to install with same message which would mean the error come from the android side.

I checked at the “autorisation of unknown application” but everything seems normal.

Any clue regarding the potential causes and what I could try ?

Do you have any extensions in your app ?

Are you running the latest versions of those extensions ?

I only have a "Wake Lock" external extension but it doesn't seems a new version as been released since 2021.

By the way I tried to reinstall another app and I have the same error message.

I just tested the app on an old device (Android 7.0) and it work perfectly.

Does App Inventor is always compatible with Android 14 ?

Try to first uninstall the old version, then install the new version


Yes it what I have done.
But none of the apk I tried to install is working,same message error every time

Is this app for your own use, if so you have to add android:exported="true" for activities, broadcast receivers to manifest file

search for android:exported

1 Like