Trouble running App Inventor


My name is Chang Min Bark and I am a potential GSoC contributor who is trying to install and run app inventor. I am running into this issue:

I have typed '/c/Users/chang/AppData/Local/Google/Cloud SDK/google-cloud-sdk/bin/' --port=8888 --address= appengine/build/war/.

However, it seems to run into a NullPointerException with the Google AppEngine, which I am not familiar with. Does anyone know a solution to this?

Thank you!
Chang Min

I don't see anything in your command that would not make this work. Does it also fail if you use the .bat version of the command in a Windows command prompt instead of the Git Bash shell?

Since this looks like it's failing pretty early on, it could be the version check. Try also adding --disable_update_check to the list of arguments to see if that helps.

Hi Evan,

Thanks for the reply. I have tried both but nothing seems to be working. Do you have any other suggestions?

Chang Min

@ewpatton Hi Evan, I was able to resolve the issue. I did a clean reinstall of the GitHub Repository and it worked. I think it may have been an issue with apache ant. Thanks!