Trouble connecting to MIT

I have the following:




I did this in C:\AI2Offline\AI2U:

  1. buildserver.cmd and leave DOS window open.
  2. startAI.cmd
  3. startInvent.cmd and it runs!
  4. closeAI2U to shut it down and close all the DOS windows!

I suppose I can write an exe to do all this and make all DOS hidden but why is my offline not working? It worked once and only once! Why do I not have WinStartAIServer or WinStartBuildServer? Obviously those two Win cmd files do what I have and can do with an exe I will create but I would rather have a working package.

BTW: when I say I don't have a WinStart file what I do is go to top of C: and do a search for "WinStart". if any such file exists anywhere on the drive it will be found. They just don't exist even if I search in C:\AI2Offline\AI2U

Thank you so much Anke. :heart:

Sure hope someone reads this and can help me to get the full package

  1. We are talking about JDK 8.
  2. We are talking about AI2Offline and not AI2U (the latter has been deprecated for years.)

1 Like

I search for "Java JDK8 Windows7" and Oracle gives me this page: Java Archive Downloads - Java SE 8 | Oracle Philippines

The page warns its a very old JDK and dangerous!

Still, even though AI2U is outdated that is what I get after installation.
I do not have WinStartAIServer or WinStartBuildServer

I downloaded AI2Offline_x64.exe from AI2Offline download | as you recommended. ??????????? :persevere:

I have always used the portable version from the beginning (also with AI2U):

You are recommending I DL AI2offline 3.9.7 and Java JDK 8 correct?
do a full uninstall of JDK 18?

uninstall everything and start over?

If you don't use it anyway, why not.
You just need to install Java JDK 8.

I DLed the AI offline 64 bit version I removed JAVA JDK18 and left JDK8 64 bit installed.
I am right back where I began with the wonderful error :frowning_face:

I then DLed 32 bit and it created a folder which has
WinStartAIServer.bat (not cmd but bat)
I click them and nothing happens !! :frowning_face:

I return to #17 above and it works :roll_eyes:

I do not understand the link you gave at all: AI2Offline / Tickets / #5 AI2Offline3.9.7z

What's not to understand there? Download and unzip it. That's all.


I did not understand because I was looking at the images as instructions and they are in Russian I think.

I deleted my Java and installed the link software and now there is no Java folder in Programs.

I uninstalled AI2Offline_x64.exe, removed the AI2Offline folder, cleaned the computer, reinstalled AI2Offline_x64.exe

I still do not have:
AI2Offine2.9 folder
WinStart files

Nothing has changed.

OK I started new using AI2 32bit which has the files in your picture.

I am so confused now from all of this. I am again attempting to DL Java JDK 8 but now it requires me to be a company to sign in and get 8 downloaded ! I cant find or DL JDK 8


Download from the following link

1 Like

For this you have to create an account with Oracle.
But not with the link I posted.

1 Like

Yup I tried that. I am retired and dont own a company. Dont have a USA phone number.
Cant get it.

NOT with the link you posted? I cant read German and I did try but cant find JDK8 for Win7.
Without a clue.

Thanks Dora but I dont have a company, not working, no USA telephone number

or use an OpenJDK

1 Like

1 Like