Timer loop stopped working

I´m working on an App, with a clock 1 with 6000 ms timer loop and a clock 2 with 180000 timer,
clock 1 should keep on searching for a web response, if positive, timer is set to false, if negative should keep on fireing until either there is a positive respones or clock 2 timer is reached. This loop was working correctly until last week, suddenly it is not working, clock 1 timer completes only the first time and then nothing happens. could it be a bug? I have the same type of time loop in another app and testing it works fine in the sema mobile

these are the block I´m using

Try using just one clock, with a counter.

If counter = 30 then do something (this replaces your second clock timer)

Something like this

thanks, I will try it and let you know the result

I have already tried this proposal, but again, the timer triggers only once, I set a visible label to record the times it would trigger. I already eliminated the another timer thar launched at the same time and set the global counter to set the timer to false but the result is the same. Any thoughts?

Hi jeduardo

Actually your code looks good:

  1. Where are you initialising the timer interval?
  2. What screen is this code on?

Next time you upload a Blocks image, capture it via the right-click menu "Download Blocks as Image".

download blocks

th app I´m workig on has 7 screens, this code is in the fifth, as I mentioned in my first emssage, it worked well, and last week just did not.
the timer interval is initialized when a "buscar" (search) button is clicked, I have changed the time interval from 3000 to 10000, with no success.

How do you know it is not simply the case that the web connection is made first time ?

timer needs a web connection to trigger? the screen initializes with the event "error ocurred" to verify internet connection, but the logic would be that the colck timer triggers at givenintervals regardless, until the expected response i received, am I right?

I will review the response from the web to verify if there is a problem

I would simplify, set up a test project to get this part of the code working, then you may see where it is not working in your main project