Timeout connecting to CloudDB

I have been using AI2 for some time and have had a couple of apps working with CloudDB.

But 2 days ago everything just failed with the same error message:
java.net.SocketTimeoutException: failed to connect to clouddb.appinventor.mit.edu/ (port 6381) from / (port 58898) after 20000ms

This is in spite of CloudDB1.CloudConnected returning True. And this is also true for a very simple 5 block test app.

Any ideas?

(I thought about using Redis but that all seems so complicated.:thinking:)

Welcome David.

The MIT server that hosts the MIT CloudDB is working normally at the moment with several large Projects I have. No one else is reporting the error constantly so a possibility is your code or your IP.

  • The server might be having heavy usage; in that case using a Redis server instead of the default server provided by MIT for testing your CloudDB Project might clear up your problem.

  • the problem occurs using WIFI or data? If you don't have a great Internet connection intermittently that could be your issue.

You might use a FirebaseDB instead of the CloudDB on a Redis server. It's Blocks are similar. :wink:

Thanks Steve.
I shall look at your suggestions.

Solved. Even though I seemed to be able to do everything else on the internet I noticed Spotify saying that the internet was not available.
So I rebooted my phone and normal operation resumed with my apps.
Thanks for taking the time to respond Steve. Hope this may help someone else in the same situation.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.