There is a bug?

What is happening???

Please provide a more detailed explanation of what you are trying to achieve,
what you have done so far, what works, what doesn’t work…

Please show your relevant blocks,
if relevant, your data or lists,
screenshots of the Designer screen or app in action,
so we can see what you are trying to do…

Right Click in Blocks Editor and select “Download Blocks as Image”
for the best image of your blocks.

1 Like

I cannot control the width, length or any properties of all elements on this screen but not others.

What happen again???

Possibly this issue (based upon your first image)

Do things look OK in companion or compiled apk ?

Not sure about the “tripped a bug” errors you are experiencing. can you give more detail about when these happen ?

1 Like

It shows the same problem when I change phone size to tablet size or any size. Therefore, I think it is not related to this.

It looks absolutely OK as same as the past that this problem hasn’t happened in the companion!

However, I still can’t move, control, edit any properties of the element on this screen but not others.

The first “tripped a bug” happened when I am trying to move an element to other places.

And the second “tripped a bug” happened when I am trying to drag another element into the screen.

This problem happened since I was moving a label to another cell of the same table arrangement.

And also sometimes this shows when I just clicked into the app at once.

Thank you for your help and please let me know what is happening as soon as possible.:disappointed_relieved::disappointed_relieved:

I can’t move, control, edit any properties of the element on this screen but not others.

The first “tripped a bug” happened when I am trying to move an element to other places.

And the second “tripped a bug” happened when I am trying to drag another element into the screen.

This problem happened since I was moving a label to another cell of the same table arrangement.

And also sometimes this shows when I just clicked into the app at once.

Thank you for your help and please let me know what is happening as soon as possible.:disappointed_relieved::disappointed_relieved:

I see the app name and screen name are obscured on your screen shots.

Did you do that?

1 Like

Yes but it is not the main point.

@Lik_Wai_Wong You are placing a LOT of objects and Labels into a Table Arrangement. Doing that is probably the issue. You have so many objects that you have to use the Monitor display to seen them all.

I suspect placing more in the Table Arrangement than can be handled by App Inventor is your issue… Placing ListPicker, DatePicker, TimePicker might be impractical. Do I know for sure? No.

There could be other issues. We do not know since you did not provide an image of your Blocks or an aia file to test. Also it seems you have multiple screens.

I would make a copy of your Project; delete this screen from the copy and try your app. If it runs without the Screen with this Table; it means you need to redesign the Screen.

Be aware, an issue exists in nb183 where switching between phone…tablet…monitor in the Designer causes issues in some apps. MIT is addressing that issue and said earlier they hoped to post a fix sometime late this week. That problem might be related to your issue. Test later in the week.

1 Like

I get your advice and I will try to redesign the Screen by putting fewer element the Table Arrangement. Thank you for your help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.