The virtual keyboard was shown as mess code in the emulator

The virtual keyboard in the lastly published emulator is not working??

What can I do to work on this ?

Is this a problem of the App Inventor, or emulator? Have you tried other emulator?

I'm quite sure I never saw that in my emulator testing, but I'm also pretty sure the final version didn't see a lot of keyboard testing. I'll see if this reproduces for me.

One option for folks who are having trouble with our supported emulator is to install Android Studio and create a virtual device there. You can download the Companion apk and drag-drop it onto a Visual Studio virtual device. If you use the Connect->Emulator menu option while a virtual device is running, App Inventor will connect to that device.

What changes to the emulator settings have you made?

  • Width?
  • Orientation?
  • Language?
  • Other?

Thank you! Kevinkun!
The previous version is working well.
But this new version (64 bit) showed the image.
What do you mean by other emulator? I dont have android mobile phone in my hand.

I am preparing to teach students doing apps in computers with windows 10.

other emulator like Blue Stack,

Thank you ! ABG,

So far I have seen these images.
I tried image 6 and image 5.
I will keep trying to figure out what are those black squares...
comparing other well-working computer in my classroom.
(:~ students's computer are fine, except the teacher computer)

Thank you Susan_Lane.

I will try Android Studio and see whats going on.

Wow~ its pretty new for me . I thought the origional emulator offered by appinventor is enough. Thanks for giving me new ideas! I will give it a try after android studio!

Hey!!! ABG!
Thank you so much!!!!

After I tried this and that with my eyes seeing nothing (all mess codes)
and reset the emulator. It works!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

T>H>A>N>K Y>O>U !!!!!!

Hmm. This suggests that the emulator relies on some fonts on the host machine rather than loading them from within the Android emulator itself, which is surprising to me. I notice that your Windows UI is mostly in Chinese, and so I wonder if the emulator is being particular about that...

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.