The blocks area did not load properly

Hi Evan,

I made a project to control an ESP32 via BLE and it was working fine till now. I made some changes with ListView today and while doing it, the following error showed up.

"The blocks area did not load properly. Changes to the blocks for screen 6690073400442880_Screen1 will not be saved".

I tried to reverse everything I did today to get rid of the error, but my work is no longer getting saved on this particular project as it looked like it has been corrupted I guess. I’ve also tried loading backup, but it didn't work as well.
I've attached the development file here:
PSPv3.aia (258.0 KB)
Can you help me to get my deleted blocks back please?

Thanks in Advance Legend

Hello Elson

Can you tell us specifically what the changes were and how they were made?

Unfortunately, the blocks can't be retrieved because they were never saved, which is what the error message says.

When you see this error message, you should reload your browser and see if you can make changes then. Don't continue to work on a project that is not saving.

Are you getting the error every time you load that project now?

How far back do your backups go?
Were the additions of the extensions other than BLE recent?


This is unusual.

I have been trying to rescue your file but there are hidden Blocks - even if the file is recreated via copy-paste, those hidden blocks carry over too. How recently was the 'Daffy' extension added? When that extension is removed, at least some of the hidden blocks are revealed and they are Daffy Blocks (you have to save, logout, login, load). Not the whole story though.

1 Like

Try this one..

PSPv3_1.aia (258.0 KB)


Looks pretty well intact, loads without complaint - I think it must be pretty close to the original state before the issue began. In particular, when I tried to rescue the file (copy-paste incrementally to a new file) I had to remake the zero4D and initGPS procedures - however, after save, logout, login, load - those procedures had disappeared.

What did you find in Screen1.bky?

Don't know how this happened, but we don't have ListView event Click and by just renaming to AfterPicking everything started to work..

P.S. therefore you get this


That's a good spot. How on earth that could happen is a bit of a mystery - perhaps a 'Click' extension that was subsequently removed. I think a lot of the more recent extensions could be more robust.

1 Like

Some lessons to learn Elson:

  1. Keep regular incremental backups on your PC drive, especially before any major change/addition. I save a backup every 15 minutes.

  2. Do not spam us!

1 Like

Thank you very much Boban. You guys have been a solid help. :partying_face:

Chris, I tried to use the following extension for listview and then I changed it back to the original ListView component in App Inventor and that's when this error may have occurred.

com.sumit1334.listview.aix (36.8 KB)(extension I used and then removed)

This has been a good learning curve for me and Thanks again guys.

1 Like

..... that may have been for the 'original' ListView component, it has recently had a huge update.

Neither the built-in list view nor this extension reference the existence of a Click event. I wonder if some interplay between either the backpack or copy/paste functionality, in combination with a Button or other component with a Click handler had a name collision and the failure mode is the result we see here.

I'm currently at a loss for how to come up with a good sequence of events that would result in a project in this state.

If you look up the filename for that extension in Google, it may say differently!!

This leads to a different confusion!!
If there is any update to the original components in AppInventor, do I have to do it manually from my end?

Possible that a 'Click Extension' was initially used but then deleted?

.... the extension has a Click event

It looks like a nice extension, has a few more advanced features. However, I just tried it in a new Project - causes the Backpack to fail - Scenario:

  1. New Project, AI2 ListView
  2. Paste ListView Blocks from Backpack - works fine
  3. Delete All Blocks
  4. Add Extension
  5. Paste ListView Blocks from Backpack - fails

Edit: Even if the extension is deleted, the Project is now corrupted.

1 Like