Target API level 31

Go to your Google Play Developer console and post a screenshot of this:

There is nothing.

Which means, you uploaded the app for the first time
Pfease read this thread to find the solutions

Ok, do you see something like this (your new app in draft status)?

If you create a new app and try to upload an AAB, Google will automatically create an app signature (even if the upload fails because of wrong targetSdkVersion (30 instead of 31).

So delete the app (draft) by clicking on the delete icon (trash, yellow marked).

I just compile my project (AAB) with this test version and submit it to Google play without any problems. Congratulations to the AI2 App Inventor technical team.

All the best.

1 Like

You should first upload it as an internal test track and wait for the Pre-launch report.

Before releasing a new app to the Play Store, I test my app on all my test devices (Android 4.x, 5.x, 7.x, 8.x, 9, 10, 11, 12). Once my app has been intensively and extensively tested on all devices and no issues / bugs were found, I upload the AAB (or APK) to the Play Developer console and wait for the Pre-launch report.

Only when no problems are found there either, do I publish the app as a production version.

1 Like

I prefer to submit directly to production. Many people wait for my completely free educational solutions. For now there are only 98 Apps published on Play stores and always in this format.

1 Like

Ok, if the apps all have the same construction, I would probably handle it the same way.

That's great, good luck on your journey.

until now, i still can't upload aadb to google store. target api must be set to 31. if i check on website mit app inventor

Built: June 19 2022 Version: nb189a
Use Companion: 2.63 or 2.63u
Target Android SDK: 30 (Android 11.0)

1 Like
1 Like

And what is the essence of your videos? What are you trying to tell us?

I don't have time to listen to (long) videos (also in a foreign language).

Hello everyone, I figured out how to publish apps on Google Play without error.
I hope this can help someone.

First install easy apk tool v1.60 on your computer.

Download your apk and put the file in the field "File / Folder" using the browse button.

1.Click the decompile button and wait for the app to decompile.
2.Click on "decompiled apk directory"

You will be redirected in the decompiled apk folder.
1.Click on your apk folder

2.Click on "apktool.yml",

and change

"targetsdkversion" from 30 to 31.

then, open "AndroidManifest.xml"

and add "android:exported="true" after all <activity, <broadcast, or <receiver

dont add android:exported to <action, or </activity.

Then recompile the app.


And you should see that when you select your compiled apk :

Then test the apk on a phone.

If the app has worked without error on your phone, convert apk to aab (you can do it on a mobile app such as APK to AAB Converter)

Finally, sign your app.


Is there anything different than what I already described in post #9?

I put examples so its easier but its kinda the same

@Thunder-thing Thanks for sharing the information, it was very helpful.

I did all the procedures you passed and everything went well and I used the ZipSigner APP ( android-apk-download/) to sign the AAB and it's giving me the following error:

Remembering that I exported the Keystore from the MIT APP Invertor itself and also tried exporting it from Kodular.

Do you know how to fix?

I really need to upload an APP to the Play Store!


Your Android App Bundle was signed with an incorrect key. Use the correct signing key and try again. It should be signed with a certificate with the following fingerprint:

SHA1: 44:8C:52:3D:35:4E:3F:D8:4F:C8:43:2C:57:1B:9B:34:12:BF:97:A4

. However, the certificate used to sign the submitted App Bundle uses:

SHA1: 61:ED:37:7E:85:D3:86:A8:DF:EE:6B:86:4B:D8:5B:0B:FA:A5:AF:81

With which builder was your previous (original) app built and signed, which is either already in the Play Store or at least uploaded to the Google Play Developer console? AI2, Kodular...?

The Application was created Kodular because I need a function that is not in APP Inventor / AI2 which is the "Network" (Network - Kodular Docs)

To sign via the ZipSigner Application I exported the Kodular Keystore, as shown in print:

Can you please guide me the correct way to sign?

Note: I'm uploading the first version and it hasn't been published on the play store yet.