Taifun Sql possable bug not copying database

I have been using Taifun Sqlite extension . It works great , nice work Taifun.

database= flatcom5.db
Table = cusinfo
colums = firstName, lastName, address, etc

Posible Bug.
I have been coding my app for the last several days and no issuses.
all the sudden it gives an error no such colums firsName, LastName, Address.
this is very weard as it happen all the sudden.

I go into my phone and look to see if the database flatcom5.db is there.
I see the database flatcom5.db.

I delete the database . I want to see if it copy's the database from my media to the phone.

It will not copy the database to the phone .
I look over my simple code and do not see any problem.
I tried this on 2 other phones with same issue.

I remembered this happen to me before and i uninstalled the extension and it worked the last time it happened.

So i uninstalled the extension and intstalled it again and that fixed it again.

Has anyone else seen this issue ?

Do you import the database on first run of the app?

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select "Download Blocks as Image". You might want to use an image editor to crop etc. if required. Then post it here in the community.


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

Here is simple block code.

Thanks for looking at this.



will only load the db on the first run of the app (screen)

Yes i am following your example .
here App Inventor Extensions: SQlite | Pura Vida Apps

Thanks for looking.

I followed your example .

I was wording why I have had to uninstall and reinstall the extension 2 times .
I can private(email, etc message you the aia file if you need it.
It is pretty basic.

Your blocks look fine..
This is what you want: on first run of the app, import the database, on all further runs use the database you already have

You said

After deleting the database you only can import the database again if the tag FIRSTRUNi in TinyDB has been removed... it seems to be you forgot that...

Are you testing using the companion app or after building the app? After you finished developing the app, build it and test using the apk file

And next time don't panic.. relax... do some simple tests... and do not delete the database... the database does not suddenly disapear... also the tables don't disapear...


Thanks for looking at this Taifun.
I tested with companion and build the apk.
Am i doing something wrong ?
Thanks again

As far as I can see, you do it correctly

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.