Successful Use of Ullis Roboter Seite MQTT extension with TLS

I was able to successfully use the Ullis Roboter Seite MQTT extension quite easily, including addition of username and user password, making a connection with my project which is controlled by a RPI. However, I have not been able to get it to work when I add in TLS/SSL. I am able to communicate with my broker (set up on one of the RPIs) both from the command line and through a python program from the GUI. On all of the RPI platforms, all that is required is the CA.crt file. I have tried adding that to the AI program and I have further generated a client.crt and a client.key and included those files without success. Does anyone have a screenshot of the UrsPahoMqttClient properties box from a successful program showing which files are required to make a TLS/SSL connection with an MQTT broker? Any help would be appreciated.

it looks like you are talking about this extension Ullis Roboter Seite/AI2 MQTT
probably the author @Ulrich_Bien can help?


Thanks. I'm new to the forum. Didn't realize I could reach out to the author directly.

Ulli has often helped me. However, he is only very sporadic here in the community. It is best to read his (as always excellent, also available in English) documentation carefully and if you have any questions afterwards, write to him via his website.

1 Like

Thanks. I will look through the documentation again and if I can't make any progress I will hit him up this weekend.

So, I've tried to beat this going on 2 weeks now with no luck. I'll still use this for unsecured communication within my local network because it works flawlessly in that scenario. However, I've tried every combination of certificates I can make and still can't get past the initial " No subjectAltNames on the certificate match" error that won't allow the initial connection. No problem establishing the computer to computer SSL connections but just can't get the Android to work with the broker. I even tried the provided certificates. I appreciate the suggestions and if anyone ever does get it to work please post a screenshot of the pahoclient properties window so I can see what combination of certificates/formats worked. This would still be my preferred method of remote comms.

hi please i don´t succeed to connect to broker hivemq using my credentials despite i connect with public broker with no pb
help please
thx in advance

hi please i find just a pb with my personnel appinventor application that doesn´t connect to my private broker hivemq using password and username
look the screenshots of my appinventor application where it show 4 after i click on button connect that´s mean it doesn´t connect

can you help me please

thx in advance

Can you elaborate on how you got the extension to work?

what version of Android are you trying it on? It works for me on 11, but it won't let me install it on 12, it gives me a package parsing error :frowning:

Hi Angelo, send me a more detailed error description to