Stops loading at 75%

For some reason, my project stops loading to my companion app at exactly 75% every time. It doesn't change or show an error message just sits there till I cancel it. It stops loading on a .png file i have on a sprite in my project. I just don't know what to do.

Welcome Nathaniel.

You did not show any Blocks relevant to your issue so we got to guess.

How large is your png?
How large is your aia?
Do other Projects load completely?
Are you using Companion or the emulator?
Has this Project ever loaded completely?

A guess is your png is large and/or you are loading lots of images or sound files. You could revert to a previous version of your Project or use right sized smaller images. Lots of other coding or your network issues could be contributing that we might be able to help with if we knew more about your Project.

I'm using the png included with the project
I actually don't know how large my aia is
No other projects load either
I'm using IOS companion
The project has never loaded completely

ios . Do you have an Android device you can test to see if the Project works using the original Companion. What you experience could be a bug in the implementation of ios which is still buggy. If you can, try your code using an Android. Unfortunately your Project will not work with the emulator of Android because it uses the Accelerator and the emulator doesn't have the hardware.

You could share your aia by dragging it to this box and someone could test if the Project runs on Android if you do not have a device,.getAIA

No other projects load. That says something is not working correctly. What? Unfortunately I do not know. :cry:

Where are you getting the example code from?

I, unfortunately, do not have an android device to test it withNate1_1_2.aia (19.3 KB)
I am getting my example code from PLTW from some lesson my teacher has me in

:slight_smile: It appears you did not unzip the file that provides the image sprite png image Nathaniel.
Do you know how to unzip a file?unzipFile

You should be able to use either or both of the two supplied images.

Not on my Chromebook no :sweat_smile:



That looks like the lesson

Congratulations Nathan. Your code works on an Android with these changes Nate1_1_2FIXED.aia (35.8 KB)

You can delete the zip file from your Media too.

Now does it load and run on ios?

It gets stuck at 83% now. I'll see if I can use one of the old android tablets tomorrow. hopefully, it'll work then.

It did get stuck on the happy png. It might just be some weird IOS bug or just some weird bug for me, because there are a lot of other people in my class using IOS and it works fine for them.

Are you using Chrome? I think it is an update with Chrome. Tried Firefox on Windows with iPads running AI Companion and worked fine. Looked at Chrome versions and found the difference. This has happened before with browser updates. Hopefully they will fix it soon.

Ok, thank you and steven for all the help.

  • are the others using a Chrome laptop?
  • are you all in the same classroom or are taking the course online?

If you are using your home network, are others using the network at the same time to view movies or listen to music etc. using up bandwidth.
Do you have a fast network?

If you are in a class school network, you may be competing with other students for bandwidth.

We are all in the same classroom in person and yes everyone is using a chrombook.

Which version of Chrome are you using?

1 Like