SQLite saving record problem in Android 13

Hi @TIMAI2 ,

I tested my app in Android 8 and everything worked well. But when I tested in Android 13, it gave this error, when I try to INSERT or UPDATE a record:

Note that the "SQL command completed" is being inserted into the record...

The blocks are this way:


Am I missing something, to work in Android 13?

what is the Do it result?


In companion it returns the command correctly. I am having this result in an APK. But I have an idea about where the error is. I'm going to try again and tell you my results.

The problem is when I uninstall the APK on device with Android 13, it's not deleting the SQLite database... so when I install again, the app does not recreate SQLite tables and the error appears when I try to insert a record... Where do I see these files on the device with Android 13? It is a Samsung Galaxy A22...

And I'm going to test with another device with Android 13.

Well I saw the problem. In Android 13 when I uninstall the app, all cache is not deleted, so I have to do this as soon as the app is installed in the device. Problem solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.