SQLite - problem

Can anyone advise me where I made a mistake? Its not working....

In what way is it not working?

  • unexpected answer?
  • error message (Show us?)
  • never returns ?
  • more than one row returns?

Check your SQL statement has the correct spaces and apostrophes, it should look like:

SELECT tempa FROM tblSynopsa WHERE id = 17 ORDER BY id

or (if your id values are indeed strings)

SELECT tempa FROM tblSynopsa WHERE id = '17' ORDER BY id

If you haven't specified an id column, you may need to use rowid instead

Thanks. You're right, ID is a numeric. But even if I fix it to .... id = 17 .... it still returns SELECT parentheses () to the gTema variable.
How to do it if I want instead of a specific number e.g. 17 compared any number stored e.g. in the gKey variable?

What is between the '(' and ')' in the result?
Does that part at least make sense?

  1. You probably do not need the ORDER BY id if all your id numbers are unique, because you will only get one record back ?

  2. Try simplifying your query:

SELECT * FROM tblSynopsa
SELECT tempa FROM tblSynopsa

Do you get results ?

You already know how to use the JOIN block, with extra sockets, to build up a SELECT statement. Squeeze a get variable block in there instead of that 17.

Hello. I tried to compose SELECT via Join. But even so, the ev4 column doesn't choose me.
If I run the select in SQLiteStudio, it works for me there. This means that db is OK.
And won't there be a problem with the bindParams clause? Isn't it necessary to set something there?

If you put the full SQL query in the sql socket, and an empty list in the bind params socket, as you have done, then the query will work.

Not quite sure why are returning a value from your query that you have just entered? Do you want to return something else from the table based upon the value you enter, or are you simply verifying that that value exists in the row/table ? Again, there is no point in using ORDER BY because you will only return one value ?

Now I want to return the value in the topic column via SELECT.
Unfortunately, it only returns me parentheses (). There is a different value in that topic column. In the database should not be created e.g. ev4 foreign key?

The SQL you are using is working for me. Check your column name: tema ?

The column name is Tema. I fixed it in SELECT
But again, it returns only parentheses () to the Al companion cell phone.

You have accented single quotes on your value, change them to non accented single quotes (as I previously suggested)





Check your column name ev4 ?

Try running all this from a button instead of Screen1. Initialise

Check you actually have the data Jn 1 25-28 in your table !

I fixed it as follows:

  1. Launch it by clicking on Button1 ...
  2. I fixed the quotes of the gKeytxt value to alt + 39 ....
  3. In SQLiteStudio, I ran the command:
    SELECT tema FROM tblSynopsa WHERE ev4 = 'Jn 1 25-28'
  4. This command returned the result to me: 17. Svedectvo Jána Krstiteľa

Unfortunately, the result of SELECT in my application is still: (), so it's bad ...
Well the error is definitely between the chair and the computer .... but where ....


Have you imported the database in those blocks ?

Yes, again

Replace tema with *, does that work ? (Did you not say earlier that the column name was Tema ?)

Unfortunately, even if * it doesn't work ... I've already tried all sorts of possibilities ...
Is there any other method for SELECT in the standard SQLite extension? I would love to have purchased your extension, I just don't have PayPal, so only pay by card ...


Not even:

SELECT * FROM tblSynopsa

Unfortunately, it doesn't even work ...