Runtime Error - Error from Companion: invoke: no method named `ShowListsAsJson’ in class

This keeps coming up with every single program I make and every program I download. It even occurs to programs that previously worked. I haven’t changed any settings in Screen 1 in my past several projects but the error is still appearing. I can’t run any of my programs because of this. Please help!


It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select “Download Blocks as Image”. You might want to use an image editor to crop etc. if required. Then post it here in the community.


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

Sounds like you didn’t update your Companion to the current version.

What version of Companion are you running?

This error is applying to all of my programs. Including ones that previously worked so I don’t believe it’s an issue with the blocks because the error appeared with programs that hadn’t been modified from their previous operational state.

Your companion is quite out of date. The ShowListsAsJson property was added in 2.40, which means you’re running companion 2.39 or earlier. Version 2.39 was released in September of 2016. We currently support companion versions 2.55 (Aug 2019) and newer.