Server Error: Cannot Upload File

For some reason, I am unable to upload files that I have used before. This is part of a class I teach. The AIA files have been used for the last two years with no problems, but now I and my students cannot upload them. What is weird is that it uploaded one correctly last week, but none of the others. The only difference in the files is the ones that will not work have media files in the project. I tried the first one that worked again just now and it uploaded without any error.

Oddly, I had my students attempt to do the PaintPot tutorial. When they went to upload the image of the cat, it also gave them the same Server Error. This makes me wonder if there is something going on with uploading media to the App Inventor site, or if it is something on our end.

Try Refresh Your Page Or Press F5.

1 Like

Currently, the App Inventor server is experiencing high usage and longer than normal build times.

I expect Projects with large media files will have issues loading. Try an experiment; make a copy of a Project; remove some of the media files and see what happens when you try to load.

If your class is using a school network with an on site classroom, the issue could be your school network sharing bandwidth with many individuals and other classes and perhaps Zoom; if these are students at home, the issue may be problems with their Internet providers due to high usage.

Does the problem occur when you load a simple Project (place a Button on a Designer, then use Companion to run it or build it). What happens. Is it loading while these other Projects are not?

Make sure your students are using the latest Companion 2.60. Using an 'old' Companion could cause issues.


I forgot to mention that this has happened across multiple days on around 25 different devices. Including computers that have been shutdown, restarted, and closing/opening the browser.

What browser are you using

The project that has worked has two checkboxes, two buttons, two text fields, and a text label. It loaded just fine. No media.

The ones with media are about 2.39 MB in size and have mp3 files, and an image used for the buttons. In the past, it has worked just fine.

Thanks for thoughts regarding bandwidth. I had not considered that before. I'll inquire to see if that could be a cause.

There are multiple ways you can test the issue Jeffrey.

  • Load the Project aia on your personal laptop and try the Project from you home router. If the Projects runs ok, the issue is probably Internet congestion and/or an over-stressed school network (or you could just be testing while the traffic on App Inventor's server is less)
  • share the aia with this community and someone will run the app and tell you what happens.

Is it possible that your IT department made recent changes on its 'white list' recently - i.e., is something not allowing the school network to work with mp3 or png/jpg files?

Okay. I tried this. I have a teacher laptop that is on the staff wifi, so a different network than students. The file uploaded just fine.

1 Like