Serial component error ( requires that one flag of FLAG_IMMUTABLE be specified)

Hello All,

I started getting this message when testing with a new phone. Specifically with the ArduinoSerial extension. I get the error installing with the companion app and with the apk. I created a new project and created a button that initializes the serial and get the same error.

I've read through several threads on similar errors and see that it is possibly a server side bug with the new version of android. Any word if this is being addressed?


Contact the third party developer of ArduinoSerial extension. . His/her extension is probably no longer compatible with Google's guidelines. Only the developer can fix the Runtime error in version 31 and above. This is not an App Inventor issue.

Maybe I was mistaken when I called it an extension. It is the built in serial component to App Inventor. Not something I installed from a third party.

What is the 'name' of the component. There isn't an App Inventor component called ArduinoSerial. Are you refering to the Serial component?

Are you using any extensions that might trip the error or the Texting component which trips the error (until the fix is moved from the test server to the main server)

Yes, I'm referring to the Serial component highlighted in the attached screenshot. I may have referred to it as the arduino serial based on the icon. I'm not using any texting components. Just trying to open a serial connection to arduino.

The code worked fine before. To test I just dropped the component into a new project and created button to initialize the serial connection. This is the code that runs when the button is clicked.

2023-01-17 09_14_53-MIT App Inventor

When the code is run on an Android 8.1, no error. When run on an Android 12 device, the code elicits

Yes there appears to be a BUG. Thanks for reporting. The MIT developers have been informed.

Thank you. I appreciate your help!

The library we use for the Serial component, Phyiscaloid, needed to be updated to address the Android 31 changes. This issue should be fixed on the test server I have previously shared on the forum.

I followed the link to the test server last night and tried it with the same result. I went to try it again just now and see error that the service is no longer support. I'm unable to build and test.

hello everybody, this is not a spam, I'm writing in several tread to find a SW patch about the problem on app inventor serial component and FLAG MUTABLE error. I tried to use the server test and it is not longer supported as written by "Shakezoola". Anybody can help me to have a build apk that can work with android 12 or 13?

There is no need to keep repeating the same thread in multiple topics. One is enough. If someone has an answer, they will provide it.

But is it fixed? Can someone confirm the test server correctly handles the Serial component and not an issue of someone neglecting to use the test server Companion instead of 2.65 ?

No, I don't think anyone can confirm because the test server is no longer supported and won't build packages. You can generate a QR code to update the AI Companion app there, but not useful for anything else.

Did you use this link


Oct '22

I have deployed a temporary server where you can test the issues related to FLAG_IMMUTABLE in the built-in components here . Extension authors will still need to separately update their extensions to be compatible with Android S.

You are right, the link is BROKEN.

@Shakezoola perhaps this link might work the test server at

@ewpatton I just tried to update the AI Companion app and received an error: "App not installed as a package appears to be invalid". Currently on 2.65d2u and not able to update.

I have yet to get it to work. There a test server link above, but I am unable to update the AI companion to the necessary version to use the test server.

Does anyone know when the fix will be published to GA?

I have just updated the test server with the latest version. You'll need to go to the Help > Companion Information dialog to get the download for the companion. The build server should also be back online.

Thanks it works very well, How long it would be on line ?

We're currently planning a release for February 15, so I've set the timeout for February 16th.


I still get the error that the package is bad when trying to update the companion app so I'll just wait until the 15th.