Sending SMS message: uid 10159 does not have android.permission.SEND_SMS

pls can any one guide why i am having this error

try to adding permissions like this :

blocks

1 Like

its not working still any suggestion

Please show your relevant block.

get an image of your blocks (→ right mouse click in Blocks area)

Are you compiling the application to APK or working with Companion? Not everything works with companion.

2 Likes

see here

see also https://www.google.com/search?q=uid+10159+does+not+have+android.permission.SEND_SMS+site:stackoverflow.com

Taifun


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

Building on @Patryk_F's response: If you are testing this with the companion, make sure you are using the version of the companion app available from our website. Google prevents us (procedurally, not technically) from including this permission in the companion app published through the Play Store. The version on our website will let you use this permission. Versions installed from the website will include a u at the end of the version number, e.g., 2.60u. If you don't see a u at the end of the version number in the companion, you will need to install the version from the website to resolve this error.

3 Likes

Hi!
I've tried to download the Companion version from the web but it says invalid link, Shoul I do anything else to download it? :confused:

This link ? (straight from the Companion Information popup)
http://ai2.appinventor.mit.edu/companions/MITAI2Companion.apk

Yes... I've tried it several times...

The link is OK, it is working here.

Thank you.

Should be my device's problem then

You could try downloading the APK to your computer and then transferring it to your device via a USB cable. Are you using a device where Chrome isn't the default browser? There shouldn't be a reason why the APK is blocked from being downloaded.