Security Issue when loading App Inventor platform

I have a classroom of 20 computers. I use a Macbook Pro. When we click on the "Create Apps!" button the new tab that opens just shows a blank screen and the address bar shows a warning. I am attaching images of both. This began last year and has persisted into this school year. Any advice?

You might read this discussion

Until App Inventor switches from http (which IS secure generally) to https you will continue to see the browser warnings provided by your browser probably. I ignore the Not Secure message
and continue to code happily. :slight_smile: I and others have been doing that for several years without issue.

MIT says it will soon implement https link to the main server.

It may just be taking a long time to load if you haven't used it in a while. Each App Inventor release typically weighs in around 5-6 MB and depending on the speed of your Internet connection it may take a while. If you have a generally fast connection and it's still hanging, there may be a caching issue. Try shift+clicking on the refresh button and see if that resolves it.

Thank you for trying to assist. I actually have left the tab open all day today and still not loading. I also tried the shift+click on the refresh button with no luck. :weary: I have cleared the cache and set my browser (Chrome) to allow for Not Secure sites. I have closed everything out and opened Chrome again. I am not sure what else to try. I have read through the other topics concerning this issue with no luck. I will see if I can test the bandwidth to see what the rate is for downloads.

A quick test would be seeing if you can access the test server, which currently we serve over both HTTP and HTTPS: If it works over HTTPS but not HTTP, that suggests that maybe your network is blocking the HTTP requests that are needed for If it works over both, there's likely another issue at play.

OK. We might be getting somewhere. =-)

It worked over HTTPS but not HTTP. So, I am guessing I need to contact my network admin. Do I just ask them to allow HTTP requests? Can they do it just for MIT App?

I imagine so, but our domain resolves to servers at Google (since that is where App Inventor runs), with the specific domain name of However, that domain resolves a whole range of IP addresses, which seem to mostly live in the and subnets, but I don't have a great way to confirm that's all of them.

Another option might be to use instead. Currently, that DNS entry points to the single IP, so the firewall rules would be easier for your IT department to implement.