Runtime Error: Targeting S+ (version 31 and above) requires that one flag of FLAG_IMMUTABLE be specified[...]

Hi and sorry for a possibly stupid question but where can i download the version 2.65d2u? The qr-code is only for 2.65d2 and i cannot find a link for download.


does anyone know where i can download the compagnion 2.65d2u? The QR code and the link always only install version 2.65d2.

I have an app that sends an SMS directly and would like to test it on the test server because the app displays the error mentioned above.

Regards, Pac-Man

This should be fixed now.

Thank you.

unfortunately, the test server can't build my app. several errors occured.

What about revealing more about these errors? See also the guide about how to ask here


I apologize if this has already been answered, I have been unable to get my phone to send text messages (Android 12) and I was wondering if there was a fix already sent out?

I've read much on this forum, tried to download the new companion app from the link you gave, tried downloading the app straight from app inventor, Googled this and tried a number of attempted fixes but just cannot seem to get the app to send a text message on an Android 12 (Works fine on an Android 10).

Any help would be appreciated and thank you in advance!


Can you confirm which version of the companion you are using when this isn't working?

Currently it is 2.65u

Ok, when using the test server you need to ensure you are running companion 2.65d2u otherwise none of the fixes will be available when you test.

Thank you, how do I find the 2.65d2u companion?

You can download it from here. For any version of App Inventor we publish there is a link and QR code available in the Help > Companion Information menu item.

Thank you, the Help > Companion Information only allows 2.65 add 2.65u and for some reason the link is not pulling anything up (could be the school's security).

@Kira_Pickett are you using the test server? The temporary fix for the issues will not work using the main App Invertor server. You must use the test server and the 2.65d2u Companion.

Please confirm you are using the test server link.

I was using the main App Inventor server earlier. I have been using the test server and the 2.65d2u Companion this week and I still just cannot get it to work, even with the simplest of code.

I have this working with apk built with your test server The sendDirect works perfectly.

When can we expect to see this fix the main server ? Thanks

This server is sending message directly .
Can this functionality be added to main server?

i am getting this isuue ,kindly help me

Specifically, which extension is causing the problem?

It happens with SendMessage as well, not just the Direct function...