Runtime Error: Targeting S+ (version 31 and above) requires that one flag of FLAG_IMMUTABLE be specified[...]

Ok, I will wait for the issue to be fixed but my comment was in response to this original comment on the thread

Did you try to build the APK on the test server, install it ... ?
If not, do it and report if the error occurs again. It doesn't do that for me on Android 12+.

Thanks for the suggestion to build the APK. I can confirm that the fix works for me for sending message directly via the app.

Fine. What issue do you have with Companion?
Post a screenshot.

I downloaded the companion app from the link given on temporary server :


The version of the companion app as shown in my phone :

The permission denied message received when the project is being tested via companion app.

I have given all the permissions to the companion app.

Yes ...


although SEND_SMS permission is declared in the Manifest & enabled in the Settings.

Correction: SEND_SMS permission is NOT declared in the Manifest of the Compannion app ( 2.65d1 or 2.65d1u). I checked it again! (Apparently I had the manifest of the regular Companion app open as well.)


Manifest - Companion (2.65d1) / permissions

Hmm. I think one of my changes may have broken that. I'm currently in the air on my way home from a conference, but I should be able to have an update out tomorrow.

1 Like

Well through the magic of satellite internet I've updated the server. The new companion number should show 2.65d2u.


Hi and sorry for a possibly stupid question but where can i download the version 2.65d2u? The qr-code is only for 2.65d2 and i cannot find a link for download.


does anyone know where i can download the compagnion 2.65d2u? The QR code and the link always only install version 2.65d2.

I have an app that sends an SMS directly and would like to test it on the test server because the app displays the error mentioned above.

Regards, Pac-Man

This should be fixed now.

Thank you.

unfortunately, the test server can't build my app. several errors occured.

What about revealing more about these errors? See also the guide about how to ask here


I apologize if this has already been answered, I have been unable to get my phone to send text messages (Android 12) and I was wondering if there was a fix already sent out?

I've read much on this forum, tried to download the new companion app from the link you gave, tried downloading the app straight from app inventor, Googled this and tried a number of attempted fixes but just cannot seem to get the app to send a text message on an Android 12 (Works fine on an Android 10).

Any help would be appreciated and thank you in advance!


Can you confirm which version of the companion you are using when this isn't working?

Currently it is 2.65u

Ok, when using the test server you need to ensure you are running companion 2.65d2u otherwise none of the fixes will be available when you test.

Thank you, how do I find the 2.65d2u companion?

You can download it from here. For any version of App Inventor we publish there is a link and QR code available in the Help > Companion Information menu item.