Runtime Error [select list item cannot accept the arguments]

I created an exact copy of my app game (famous person puzzle) with also same exact code blocks, but somehow my new app game got runtime error even though I created it with exact same code blocks as the original one.
=> Original one.

=> The new one.

The error message is trying to tell you, that your index is an empty string... this should be a number...

EDIT: first call the Probability method, then the Printer method...


That's the weird part. My original game doesn't have runtime error like that. I tried to create 2 more exact copies to make sure I didn't miss any code blocks based on the original game, all of it got the same runtime error ..

  1. Original Game on AI Companion

  2. Copy of the game

I can't tell you why your original version worked, but you should definitely change the default init value of your two global random_... variables to 1, not blank.

Check edit of @Taifun 's edited message he told that in second pic you are calling print before probability

Thank you so much @Taifun! It fixed my game! so I need to put the block in an orderly manner. Thank you, everyone, for the help and replies!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.