Right click on blocks worksheet responds randomly

When I try to get a drop-down list of commands by right-clicking a blank space on the blocks worksheet it often (about 30% of the time) responds by executing a random command such as disabling all blocks or scattering them randomly. This means that I have to go through a process of backing up worksheets and reloading the APpp inventor program in order to try again.

This happens independently of whether I use a mouse or pad to control the cursor.

Any advice much appreciated

Have you tested with another mouse or browser or computer?

Thanks for your suggestion. A long time ago I had the same problem on another computer. The problem is intermittent and I'm wondering if it's related to internet speed. It's Friday afternoon here and there may be more than usual activity as COB for the weekend cuts in.

I've just noted that the dropdown command list appears when I press the mouse's right-hand click button and then disappears producing a random command when I release the RH button. I then tried holding down the RH button while navigating with the cursor and then kept it held down while I selected the command with the LH button. This seems to be quite reliable - is it the preferred method?

No, just one right click to pop-up the menu, which stays on screen until a left click in space to dismiss it or a left click to select.

  1. Use only Firefox, Chrome or Safari
  2. right-click in an area well away from the Blocks (not in between blocks for example) as the accuracy of your mouse could come into play.
  3. Organize your Blocks as a single Column ("Clean up Blocks" in the right click menu)
1 Like

Hi Chris,

Thanks for that succinct description of the correct procedure. Everything you describe is exactly what I have been doing for several years. I use Chrome, always organise the blocks in a single column, right-click in a block well away to the left of the blocks, release the right click, so the drop-down command list stays on the screen, and then left-click on the drop-down list to select a command. The problem is that the drop-down box doesn't always stay on the screen and when it vanishes it selects an unwanted command.

The method seems to have changed. What works now is to hold the right-click-button down to display the drop-down list, keep holding it down while positioning the cursor over the desired command, and select the command by releasing the right-click-button. This works for me whether using a mouse or a touchpad.

I changed to Windows 11 before restarting to use App Inventor and I can only think the drivers to the mouse and touchpad have been altered in the Windows 11 update.

Your comments were reassuring as for a while I thought that I might have been using an incorrect procedure all these years.

This also happened to another user:

but it seems @Andy_Droid just came and went, not providing any background info.

Possibly not a bug introduced by nb191 on Feb 17th 2023, given his post was in January, so you may be on the right track with Windows 11, though we may have expected to hear from others ?

Have you tried loading up AI2 in an incognito window, which would not load extensions / other things ?

Or in Firefox ?

Also try using code server if using main AI2, or vice-versa ?

.... take a look in the Control Panel and examine the mouse setup.

I too think Firefox is worth trying, not least because it's currently the fastest host of App Inventor. If you leave Chrome as-is for everything else (as I did, now that role belongs to Opera) and just use vanilla Firefox for App Inventor, that might make a difference.

I do apologise for not following up on this problem in the original post, and have just seen this one.
I'm just doing some tests now as I write this.

It doesn't need a left click on the pop up menu, Right click brings up the menu and highlights an option, releasing the right mouse button selects the option.
Depending on the location of the pointer in the window denotes where in the list you will end up selecting.

Windows 10 Chrome browser

More observations! If the box pops up to the left of the pointer, then the pointer is outside of the box and no problem. If the box pops up to the right of the pointer, then the pointer is on and highlighting a menu item.

I notice that the standard Chrome pop up menu always displays the menu position with either the top left or bottom left corner positioned at the pointer. and not over a menu item.

Hi I feel your pain, I have learned to live with this, thanks to the undo menu item. If I intentionally want to use the menu, then click and hold the mouse button until I'm on the item I need then release.
Its the accidental right click that's the problem.
As I use a few 3D cad programs, the right button is used to scroll around the model, and my old brain thinks I can use it to scroll around the work space in App Inventor.
Its defiantly not a windows 11 issue as I'm on windows 10.

1 Like

This is actually a bug in one of the libraries we use where it accepts a mouse up event from any mouse button, not just left click. In rare circumstances, one presses down the right mouse button to open the context menu, but it positions itself underneath the mouse cursor and then the mouse up event for the right click immediately activates whatever option ends up under the cursor.

1 Like

Exactly. This was covered in another similar topic.

Not that rare! I guess it won't get a fix anytime soon, as its been an issue for a long time.
Not complaining, as App Inventor is an awesome utility.

1 Like