Reset companion not working

On afternoon (UK time) of Monday 27 Nov selecting the Reset Companion action from the drop-down created the following error message.

Message is: says
‘An internal error has occurred. Report a bug’

It was working fine early Monday at 1.00 am UK time and was ok all over the weekend.

Just checked again at 9.30 am (uk time) Tuesday 28 Nov and same error message received.

Please advise. Thanks

Are you using latest version of companion 2.69 or 2.69u ? This error occurs in all projects or only in this one? For me no error occur when reset is pressed

Thks Ria,

Using 2.69u.

Checked again, happens on all projects.

What is odd, to me, is that clicking on AI Companion on drop-down takes me through to QR code etc. So it seems to be the Reset Connection selection that is the problem.

I’ve always used Reset before AI Comp - does it matter??

After updating Chrome to Version 119.0.6045.160 (Official Build) (64-bit) for windows 10 and
working on with companion 2.69u I got the same error while pressing reset connection

or by pressing Cancel

Same error also occurs with Firefox. Most probably is a bug related to the latest release and will be fixed soon

Thank you for the report. We added code in nb195 that cleans up some state that wasn't being properly reset when that particular menu item is used. However, before the first successful connection that state object doesn't exist, which triggers the error you are seeing. Our team has come up with a patch and will work on getting it deployed.

Note that the first time you open a project there isn't any connection state to be reset, so it should be fine to just ignore this error for the time being.


Thanks Ewan, v impressed with your speedy response. Also pleased it wasn’t my dodgy digits.