Remove WebViewer Zoom In/Out Button

I want to delete the button in this red. However, no matter how hard I look, there are no settings related to the button. If you know how to delete it, please let me know.

I wasn't able to find anything either, but it may be present in the CustomWebView Extension.

2 Likes

To control visibility of zooming control buttons we need to set settings of the WebView and for that we need to add new designer properties in WebView component.

I think it's good idea if you file the new feature request on GitHub issue.

3 Likes

If it is your own web page you can add this to your <head> section:

<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">


this will also prevent zooming.

Otherwise, use the customWebView extension

4 Likes

Using custom webview as suggested all you have to do is un check Display Zoom from properties

image

1 Like

There is no change even though the display zoom is turned off on custom webview.

There is another setting: ZoomEnabled that you need to set to false

It's the same even if Zoom Enabled is false. ㅠㅠ

I assume you are assuming that disabling property of Customwebview will hide zoom controls from Webviewer. Is it something like that?

1 Like

Whatever I do, it doesn't disappear. Will it disappear if I install a new app inventor?

This works for me

image

the order of things may be important

3 Likes

I solved it this way. Thank you so much!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.