Project installs but will not open

My project runs fine on my phone via AI2Companion, but when I download the --apk and install it via email, no OPEN button is shown. How to run it?

Your phone has an option to list all the installed apps alphabetically by name, right?

If it's not on that list, it has not been installed yet.

Why not install it directly, as you have for the Companion? Not many email systems out there permit the attachment of APKs, so it is not a good choice for distribution these days.

1 Like

Thanks. My app is listed as installed, with the logo icon displayed before the name. But this icon is not displayed in the App Drawer display of all apps. Perhaps I have coding/block error, but no screen shows Warnings.

Thanks. My email app has setting to allow apps from unknown owners. How do i install directly from the AI2 Companion ? I tried both download and link options after apk is generated..

Thanks again. I chose the "install directly" option but it generated a MIT link which seem to install the app, but when I click [Open] the android (V8..) install procedure is initiated and I get the same result- installs but has no [Open] option !!

Are you talking about the Android equivalent to the Windows desktop?
Not every installed app gets front row billing like that,unless you drag it into the place you want it.

Thanks again. I just learned I have a logic error in my app. My bug may be the problem. I will report to you later !!

1 Like

Logic error has been fixed but problem persists.. App is an update whose original installed and ran fine, Too many screens is not the problem, only 9 included !!!

Please try this Gerald:

  1. On the phone, uninstall the App and delete the APK
  2. Deselect your icon image in the Project (will default to App Inventor Icon on Build)
  3. Build the APK and download to your phone via the MIT WiFi Scan (thus we know there is no corruption introduced by using email).

Thanks for the suggestion. Followed your instructions, but app still shows install [Done],but no [Open] on the phone.. Since I added a screen in this update, I removed the screen to see if size was the problem. but it installed with the same bad result. It is interesting that the previous version of app builds, installs, and opens correctly. I shall keep checking my code. I assume the build is lacking whatever enables Open,

Have you been increasing the VersionCode for your project? It may be that your Android phone doesn't see it as an upgrade since the version number isn't changing.

HI, thanks for your suggestion. Yes, I increased the version name and version code before building apk..

Can you share your apk by uploading to gdrive so we can give it a try

Not familiar with gdrive. How do I do that ?

Upload the file to and share the link to it

File carworklog.apk is uploaded, but how do I identify the link ?

Sorry, file is carworklog5.apk.

1 Like

For your issue, I'm suspecting something like in this thread