Problems with files over 50 MB

I followed the forum's advice, but it didn't work:
APK Editor Studio v1.4.0 and not even the laptop: APK Editor Studio v1.7.1.
I decompressed the file with bandzip, inserted the audio files (20) of 2.50 MB each, or saved everything and inserted the .apk into the phone which did not load it, without giving any explanation.
How can I solve the problem?

Furthermore, I seem to have understood that when .apk files are no longer supported there will no longer be any possibility of installing .aab files on the mobile phone, but only from the play store.
It's not up to me to judge Google's choices (I hope I misunderstood), but this is really a bad choice and bad news, many who created apps for their own entertainment will no longer be able to do so.
Really bad news if confirmed.

1 Like

Is your question related to this one?

Anyway, you can always create an APK and install it on any Android device. AAB are only required for the Play Store. I have been subsequently inserting large audio files (up to 90 MB) using AKP Editor Studio (previously A2M) for more than 10 years without any problems.

As I wrote, APK Editor Studio doesn't load my apk and therefore I can't carry out the operation that you can do well even with 90 MB.

I read in the forum that it also happened to others, so not knowing how to proceed, I opted to have the user download the audio file when he needed it and I relied on your blocks that I found in the forum, but I was only able to use the one that downloads the file works perfectly, but when I try to start it by taking the file from the path where it was downloaded as in the images, the audio file doesn't start.

As I said, do not hard-code the ASD.
Post the aia or send it to my via PM.

Note: This is not a permission for others to contact me via PM. Please only do this if I allow you to do so.


1 Like

Fantastic, a really useful help like all the others, but with this I solve the problem of the project being larger than 50 MB by making the user download the file.
Thank you

1 Like

Good morning everyone.
Please I need to resolve this issue.

  1. send an audio file to the drive
  2. I listen to the file in the drive
  3. everything ok
  4. then I download it to my phone
    As can be seen in the .aia file
  5. I go on to listen to the file on my phone, everything is ok.
  6. I proceed to download multiple .mp3 files
    They are all downloaded perfectly and you can listen to them all in the drive.
    But when I listen to it on my phone the files are not played and they are all corrupted, even when using different players.
    So I try to download just one again, but from this moment on even the individual files don't work.
    Thinking that it was Google Drive's fault which corrupted the file during the download, I wrote to Google who intervened, but the problem continues to exist.
    I carry out another test, I send the files to another server, "Altervista", hoping that everything would work, but even in this case nothing, even a single file on the phone appears corrupt.
    You can try it for yourself, which makes you think:
  7. Android in the two phones I tested "Android 6 and Android 10" have protection that does not allow the download of mp3 files from a server to the default folder?
  8. that the blocks I use are the problem?

/ is missing

Yes, but it's not the one that doesn't play the file, because I start it from the phone folder where it was downloaded regularly and it doesn't work with any player, like all the others I've downloaded.

Try to test it yourself by inserting an .mp3 audio file into your drive and then downloading it into the project's default directory and you will realize that even if you don't listen to it from the app you don't even listen to it from the same folder or even if you transfer to desktop.

I don't think I'm the only one who has inserted audio files into the drive and then downloaded them, has anyone else had the same problem?
Am I the only one who's unlucky?
Sure I'm distracted, but not in this case.
I did test after test but nothing worked.

Many people do this

Seems you are the only one, but it could be due to your syntax and path errors....

This works just fine (tested companion):

1 Like

Try this one: scaricafile_2.aia (20.0 KB)

Try my .aia and then we'll know if it's my phones that don't work or something else.
As mentioned, the file is downloaded but corrupted.
scaricafile (1).aia (2.0 MB)

Your download url is incorrect, despite @Anke telling you to change it!

You have:

it should be

I hope you tried my .aia, what happened?
The link to the new file I inserted: 01-English.mp3.

And the link you saw in Anke's blocks I replaced with this: 01-English.mp3 - Google Drive

which is what the file sharing drive gives me.
I had posted the link in Anke's blocks for the first file I attempted to transfer.

I tried the blocks but the file doesn't work

Delete all files in the ASD of the companion app, then try again


Always done, I delete them every time something is wrong.

But now I can add that I did some tests and I'll tell you how they went.
1)With the new anke blocks it didn't work.
2) even though I know that with your blocks it is not necessary to request write permissions, I wanted to insert them anyway.
3) finally the file downloaded optimally and I listened to it.
4) then I re-tested and removed the permissions, the file is corrupt.
5) I reset the permissions and the file is still corrupt.
Do you understand something about it? I do not!
6) would it be enough to understand why when I entered the authorizations everything worked, and then with the same authorizations nothing worked?
scaricafile_2.aia (20.1 KB)

I did another test.

  1. I inserted the same folder where the files are downloaded into the default folder. the original file.
  2. I started the app, which worked as if it had downloaded the file and when I pressed play the file listened to it perfectly.
    So something happens in the file transfer.

You are not listening....(reading...)

1 Like