Problems serial port

I have tried to run a program that worked on android 11 over another with version 12, but when trying to activate the serial port, this message appears. I would appreciate if someone knows how to solve it.

Screenshot_20230325_095756 (002)

On the other hand, and since we are talking about the serial port, is it possible to charge the device while using the serial port? I have tried a cable with a double OTG connector plus another one for charging, in this case in Android 11, and communication through the serial port is blocked when connecting it.


Are you using the built-in Serial component or some extension?

The standard off app inventor.

Try again on the test server.

Unfortunately that is a known bug - it affect a number of App Inventor functions and extensions. Looks like this one was not discovered. It means you cannot use it.

Thank you all for your quick response, at least I know it will be resolved in the future.

Try this extension:

1 Like

Do you use any extensions in your app?

Yes , Taifunfile . I have tried with Serial OTG and if I have not done it wrong the result is the same. But my intention is to continue working on Android 11.Maybe it's better not to modify too much, it's a very long program.

Sorry if I was not clear in my answer:

Se the following:

Also in Appinventor-SerialOTG/
230126 Ver 1.5 beta is available under Arduino-Debug directory
Uppdated com.SerialOTG.aix, SeraialOTG.aia, SerialOTG.apk
Changes: Compatible with Android12

From what I've seen, Ewan also updated the physicaloid library, so the built-in component shouldn't be a problem.

Indeed, I have tested the SerialOTG extension in the version of 2023-01-25 and it works without error. Thank you everyone for the help.

Fine, glad to hear that. It's time to update the main directory to avoid confusions.

please share me an 2023 version of Serial OTG extension you are using.

Click on this link and download the aix file does not work?

led.aia (191.1 KB)
when i am try to build the above .aia it show me message

Don't post the same thing in two threads. You created a topic about this error, so write there. To update the extension please download it from github.

1 Like