Problems of downloading images from google drive

Hi, I know this kind of question has been asked for many times, but I still can't fix this problem, sorry.
I want to download images from google drive, and I try to use the way I have found on the Internet.
But it keeps saying"Cannot parse text argument to "list from csv table" as a CSV-formatted table."
Is there something wrong with my sheet file or blocks?
Here is my sheet file:
DownloadImages.aia (5.7 KB)

Can someone please help me with it? Thanks a lot!

1 Like

And here is my image folder:
My google script to run the sheet:

Thanks again.

1 Like

More images would be upload into my drive because our lab wants to use those pictures to do some analysis. And we hope we can do the analysis on a mobile app.
That's why I try this way to get images because there will be lots of images to download from google drive.
But if there's another solution to achieve, I'm glad to try it!
Thanks in advance!

1 Like


This is about google drive, not free web hosts.

Also please do not spam unrelated material in your posts, you already have your app in the App Showcase for people to see.

I will have a look and see if I can find the issue for you

Thanks. Truly appreciate your help!

@Meulencv This again is not helping!!

Your sheet with filenames and file IDs is good.

I have edited your download url to:

Your blocks work and download all the files without error.

Depending on your Android version, if Android 10 or 11, when testing in companion the download file path will be inside


Remember to clear the tinydb tag and refresh your companion when testing

Hello, sorry for bothering you :disappointed_relieved:
I edited my download url, but the same error showed up.

I'm using the emulator for connection. Do I have to change the download file path?
And I'm sorry that I don't understand what does "clear the tinydb tag" mean...

Thank you so much again.

Try your blocks like this:


Do you get the same output ?

Uh oh, no. It turns out like this.

Hmmm an issue with the emulator and connection method. See here:

Can you try connecting your real device via USB, or install an alternative emulator like genymotion ?

Note: there are emulator/real device connection issues at the moment with the companion, but with a legacy connection it is working fine for me with genymotion.

Okay! I'll try these ways! :smiley:

I borrowed Android phone from my dad and used AI companion for connection.
And it works!!!
Oh my, I have tried to fix this problem for two days.
You really help me a lot. Thank you so much. And I wish you all the best! :smiling_face_with_three_hearts:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.