Problem with message Server error: could not build target. Please try again later!

Dear all,
is there something wrong at server level ?
Since yesterday, from Italy, I cannot compile any longer. Only very little apps are compiled and very slowly.
Bigger apps (absolutely unmodified !) are not compiling. I've used different browsers and different PC's, but the error is still the same,
Any thouhgts about ?

You could use

1 Like

Note that if you want to update an old version made with AI2 keystore is different in code.appinventor... so you have to export it from AI2 first and import it to code...

Dear @dora_paz,
Thanks for your answer, I dit it, so a new empty page has opened, Then I ried to import an .aia, but the message has been:
Server error: could not upload project. Please try again later!
Then I changed the router: from my home router to my phone as hot-spot and it has worked.
Before I investigate more on my home router what is the difference (with respect to my previous
link and the link you told me ?
Many thanks !

PS :face_with_hand_over_mouth:Sorry I've seen the difference "code.appinventor..." instead of "ai2.appinventor..."
This means that I have to move all my .aia's there ?

1 Like

No but it is a solution if AI2 server in not working

Ok, got it !
Many thanks.
In any case I've just moved the most important .aia's there, I've recompiled (and downloaded the relevant apk's) and it has worked.
You saved me!!!.
Have a great Sunday ... :+1:

PS Now it works (the new link) also with my home router...pretty weird and "mysterious"... :rofl: :rofl: :rofl:

1 Like

hi Dora_paz

i had the same problem as Uskiara and i did all the same steps you mentioned, but, when i try to instal the app in my cellphone a pop up message show up warning that its not unninstalled because it came from a unknown source.

Can you help me , please.

i did the proceeds on play protect so that i can download without problem, but still i m no beinb able to run the app.

That's normal Android app hygiene.

It's like "Don't take candy from strangers".

This is your own app that you coded, so it's as safe as you yourself made it.

Hi all,
one thing more (maybe related to security policies) : when I tried to install the app "recompiled" on the backup server (code.appinventor) on my device, it won't install any longer unless I changed the name of the app.
In other words: if i try to install the newly compiled version of the app with the same previous name, it does not install (i.e. ovewrite). If I change the name of the app with a new name (i.e. oldname_01) it does the job.
(I remember when I was storing my code on the EPROM 2716... :rofl: :rofl: :rofl:.)
Best wishes to all.

Dear @dora_paz ,
Sorry to bother you, but I' d like to have your hint:
I've just tried few minutes ago (Italian time 09:00 PM) the ai2.appinventor server and it works again !
So, according to your experience: shall I revert to this server or shall I remain in the code.appinventor one ? As you can easily understand by "jumping" from one server to the other it could lead to a mess with sources and compiled versions (as I posted previously, to have the possibility to reinstall the apk's on my device I must change the apps names ... :pensive: ).
Many thanks and kind regards,

I had the same tekst at my PC and I could not compile my projekt.
I solved it by closing VPN by Kaspersky Security and when I had done this, it all worked again.
Per Saul

Hi dear @Per_Saul,
thanks for your advice, Honestly, before applying the community I did some experiments: I had changed the browser, the security settings, the router...(and I haven't any VPN set). I've tried also to change the AV settings, but no results, until @Dora_Paz suggested me to change the server.
Anyway, yesterday, without any other changes is my original settings, the ai2 server worked again..
I'm a bit confused, but since it works :innocent: :innocent: :innocent:
Thanks a lot to all and have a peaceful time.

I think it was a 'BUG' and not as I thought 'VPN' that caused the error, because I have installed 'VPN' again and everything is right, so far.

1 Like

Hi @Per_Saul,
the theory says that even the most tested SW has always a bug (inside)....
I have written code since year 1980, so let's think how many bugs I left in my code :grimacing: :grimacing: :grimacing:

Hi uskiara
What you say I know very well. I have worked in the 'IT' business since 1985, so I know you are completely right :blush: :grinning_face_with_smiling_eyes:

1 Like

:rofl: :rofl: :rofl:
Great !!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.