Problem with localization sensor

Hello, I've trying to use a compiled app (apk) created with App Inventor and I'm struggling with the location sensor. It seems that the app can't get the coordinates. I've tested a lot of stuff and discovered that when I open Google Maps in parallel it works!

I've recorded a video on this (it's in Portuguese, but translation cc is activated):

My smartphone is a Samsung S10+ / Android version 12

Any thoughts on this weird behavior or how can I correct the app?

OBS: The exact same behavior is occurring with other apps I've created using location sensor as well.



Welcome Nathalia.

The blocks look fine. What happens if you use an Android that is not Android 12?

It appears from the video you are capturing the coordinates.

What is LocationSensor1.TimeInterval set to? I suggest you set it to perhaps 20000 or 30000.
You do realize that the first LocationChange event might take 60 seconds or more with subsequent changes more rapidly.

Hello Steve, thank you for answering! I've tried setting it to the minimum and it worked perfectly! :grinning:

The weird thing is that before when it was set to 60000 it worked fine in other smartphones (almost getting the coordinates immediately), so I thought it was a problem with my app/smartphone/configs/etc. Setting TimeInterval to 0 solved the problem!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.